summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/xoscope/xoscope-2.1.ebuild')
-rw-r--r--sci-electronics/xoscope/xoscope-2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-electronics/xoscope/xoscope-2.1.ebuild b/sci-electronics/xoscope/xoscope-2.1.ebuild
new file mode 100644
index 000000000000..a8352fa4349c
--- /dev/null
+++ b/sci-electronics/xoscope/xoscope-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils linux-info
+
+DESCRIPTION="Soundcard Oscilloscope for X"
+HOMEPAGE="http://xoscope.sourceforge.net"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtkdatabox
+ virtual/man"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~!SND_PCM_OSS"
+ERROR_SND_PCM_OSS="CONFIG_SND_PCM_OSS is needed to support sound card input via /dev/dsp"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-man_no_-Tutf8.patch
+
+ eautoreconf
+}