summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/eden')
-rw-r--r--sci-chemistry/eden/Manifest1
-rw-r--r--sci-chemistry/eden/eden-5.3-r2.ebuild88
-rw-r--r--sci-chemistry/eden/files/5.3-makefile-fixes.patch60
-rw-r--r--sci-chemistry/eden/files/eden-5.3-format-security.patch96
-rw-r--r--sci-chemistry/eden/files/eden-5.3-impl-dec.patch28
-rw-r--r--sci-chemistry/eden/files/makefile-fixes.patch25
-rw-r--r--sci-chemistry/eden/metadata.xml12
7 files changed, 0 insertions, 310 deletions
diff --git a/sci-chemistry/eden/Manifest b/sci-chemistry/eden/Manifest
deleted file mode 100644
index ef7017e4ec14..000000000000
--- a/sci-chemistry/eden/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST eden_V5.3.tar.gz 1139981 BLAKE2B 237f054accbba72fcde3a43716915a8037412a26aee861839c4a6e404276126a3955e6e0a3c76078b2253658f3ab9bcf8ad628bba059421c5171d0394c41052b SHA512 c59d08004bdb72ef39fe205aef546fbcff9c57ee42942c0391052de9c501c7793ed3bd280569020c2b9ec6133a87362d184a2012b61c6be18b5f6ba9b59716c5
diff --git a/sci-chemistry/eden/eden-5.3-r2.ebuild b/sci-chemistry/eden/eden-5.3-r2.ebuild
deleted file mode 100644
index 8bf667224ba8..000000000000
--- a/sci-chemistry/eden/eden-5.3-r2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-r1 toolchain-funcs
-
-MY_P="${PN}_V${PV}"
-
-DESCRIPTION="A crystallographic real-space electron-density refinement & optimization program"
-HOMEPAGE="http://www.gromacs.org/pipermail/eden-users/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="double-precision"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- sci-libs/fftw:2.1
- sci-libs/gsl
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${PN}"
-
-SRC="${S}/source"
-
-pkg_setup() {
- export EDENHOME="${EPREFIX}/usr/$(get_libdir)/${PN}"
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-makefile-fixes.patch \
- "${FILESDIR}"/${P}-impl-dec.patch \
- "${FILESDIR}"/${P}-format-security.patch
-
- sed -i \
- -e "s:^\(FFTW.*=\).*:\1 ${EPREFIX}/usr:g" \
- -e "s:^\(LIB.*=.*\$(FFTW)/\).*:\1$(get_libdir):g" \
- -e "s:^\(BIN.*=\).*:\1 ${D}usr/bin:g" \
- -e "s:^\(CFLAGS.*=\).*:\1 ${CFLAGS}:g" \
- -e "s:-lgsl -lgslcblas:$($(tc-getPKG_CONFIG) --libs gsl):g" \
- ${SRC}/Makefile || die
-
- if ! use double-precision; then
- sed -i -e "s:^\(DOUBLESWITCH.*=\).*:\1 OFF:g" ${SRC}/Makefile || die
- EDEN_EXE="s${PN}"
- else
- EDEN_EXE="d${PN}"
- fi
-}
-
-src_compile() {
- emake CC=$(tc-getCC) -C ${SRC}
-}
-
-src_install() {
- emake -C ${SRC} install
-
- python_foreach_impl python_newscript python/${PN}.py i${PN}
- python_foreach_impl python_domodule python/FileListDialog.py
-
- rm python/*py || die
- insinto ${EDENHOME}/python
- doins python/*
-
- insinto ${EDENHOME}/help
- doins help/*
-
- insinto ${EDENHOME}/tools
- doins tools/*
-
- dodoc manual/UserManual.pdf
-
- cat >> "${T}"/60${PN} <<- EOF
- EDENHOME="${EDENHOME}"
- EOF
-
- doenvd "${T}"/60${PN}
-
- dosym ${EDEN_EXE} /usr/bin/${PN}
-}
diff --git a/sci-chemistry/eden/files/5.3-makefile-fixes.patch b/sci-chemistry/eden/files/5.3-makefile-fixes.patch
deleted file mode 100644
index 632358341784..000000000000
--- a/sci-chemistry/eden/files/5.3-makefile-fixes.patch
+++ /dev/null
@@ -1,60 +0,0 @@
- source/Makefile | 17 ++++++++++-------
- 1 files changed, 10 insertions(+), 7 deletions(-)
-
-diff --git a/source/Makefile b/source/Makefile
-index 46d89cc..aa751c7 100644
---- a/source/Makefile
-+++ b/source/Makefile
-@@ -78,8 +78,10 @@ CFLAGS = -Wall -pipe -g3
- #CFLAGS = -Wall -pipe -marchi686 -pedantic -gdwarf-2 -g3
- #CFLAGS = -Wall -O3 -march=i686
- ifneq ($(FFTW),/usr/local)
-+ifneq ($(FFTW),/usr)
- CFLAGS += -I$(INC)
- endif
-+endif
-
- # NOTE:
- # DOUBLESWITCH = ON for double precision;
-@@ -91,15 +93,15 @@ endif
- DOUBLESWITCH = ON
-
- ifeq ($(DOUBLESWITCH),ON)
--LDFLAGS = -L$(LIB) -ldfftw -lm
-+LIBS = -L$(LIB) -ldfftw -lm
- CFLAGS += -DDOUBLE
- TARGET = deden
- else
--LDFLAGS = -L$(LIB) -lsfftw -lm
-+LIBS = -L$(LIB) -lsfftw -lm
- TARGET = seden
- endif
-
--LDFLAGS += -g -lgsl -lgslcblas
-+LIBS += -lgsl -lgslcblas
-
- # GSL_PREFIX:= /sw/lib
- # LDFLAGS += -l$(GSL_PREFIX)/libgsl.a -l$(GSL_PREFIX)/libgslcblas.a
-@@ -120,17 +122,18 @@ OBJ = addmaps.o apodfc.o apodfo.o back.o cadhkl.o \
- all: eden fbyteswap
-
- eden: eden.o $(OBJ)
-- $(CC) $^ $(LDFLAGS) -o $@
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- fbyteswap: fbyteswap.c
-- $(CC) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
-
- install: all
-+ mkdir -p $(BIN)
- mv fbyteswap $(BIN)
- mv eden $(BIN)/$(TARGET)
- chmod 751 $(BIN)/$(TARGET)
-- chmod +x mkeden.csh
-- ./mkeden.csh $(BIN) $(BIN)/$(TARGET)
-+# chmod +x mkeden.csh
-+# ./mkeden.csh $(BIN) $(BIN)/$(TARGET)
-
- dist: clean
- cd ../..; tar -cvf eden_$(VERSION).tar --exclude CVS --exclude \#\*\# --exclude \*~ --exclude Misc --exclude .\* eden; gzip -f eden_$(VERSION).tar
diff --git a/sci-chemistry/eden/files/eden-5.3-format-security.patch b/sci-chemistry/eden/files/eden-5.3-format-security.patch
deleted file mode 100644
index 04b5ecfddebb..000000000000
--- a/sci-chemistry/eden/files/eden-5.3-format-security.patch
+++ /dev/null
@@ -1,96 +0,0 @@
- source/back.c | 2 +-
- source/concosts.c | 4 ++--
- source/count.c | 4 ++--
- source/eden.c | 2 +-
- source/util.c | 4 ++--
- 5 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/source/back.c b/source/back.c
-index fd517b9..185a02b 100644
---- a/source/back.c
-+++ b/source/back.c
-@@ -112,7 +112,7 @@ void back_main(int argc, char *argv[])
- ballpark(caller) ;
-
- if (argc > optind+2)
-- sprintf(sf_filename, argv[optind+2]) ;
-+ sprintf(sf_filename, "%s", argv[optind+2]) ;
-
- /*********************************************
- Pull off prefix defining whereabouts of input
-diff --git a/source/concosts.c b/source/concosts.c
-index d62d2e3..590f073 100644
---- a/source/concosts.c
-+++ b/source/concosts.c
-@@ -452,7 +452,7 @@ void prepare_singlets(char *filename)
- sprintf(message,
- "s=%d, p=%d, n=%d, phase=%g, old phase=%g, delta=%g\n",
- s, p, n, phase, *(checks+n), phase-*(checks+n)) ;
-- fprintf(fp_log, message) ;
-+ fprintf(fp_log, "%s", message) ;
- }
- }
- /***********************************************
-@@ -556,7 +556,7 @@ void prepare_triplets(char *filename)
- sprintf(message,
- "Triplet (%d %d %d) from input (%d %d %d) corresponds to point w/o fobs info!\n",
- newh, newk, newl, t_h[q], t_k[q], t_l[q]) ;
-- fprintf(fp_log, message) ;
-+ fprintf(fp_log, "%s", message) ;
- legal_triplet = FALSE ;
- }
- }
-diff --git a/source/count.c b/source/count.c
-index c3bc390..ca13008 100644
---- a/source/count.c
-+++ b/source/count.c
-@@ -460,12 +460,12 @@ void print_el_count(char *filename,
- }
-
- sprintf(message, "\nTotal no. of electrons is %g\n", totnump*volvox) ;
-- fprintf(fp, message) ;
-+ fprintf(fp, "%s", message) ;
- printTwice(message) ;
-
- sprintf(message, "Count of all remaining electrons: %g %g %g\n",
- remainder0*volvox, remainder1*volvox, remainder2*volvox) ;
-- fprintf(fp, message) ;
-+ fprintf(fp, "%s", message) ;
- printTwice(message) ;
-
- fclose(fp) ;
-diff --git a/source/eden.c b/source/eden.c
-index dea3246..5a9b389 100644
---- a/source/eden.c
-+++ b/source/eden.c
-@@ -319,7 +319,7 @@ int main(int argc, char *argv[])
-
- get_unique_logname() ;
-
-- sprintf(command_line, argv[0]) ;
-+ sprintf(command_line, "%s", argv[0]) ;
-
- for (k = 1; k < argc; k++) {
- strcat(command_line, " ") ;
-diff --git a/source/util.c b/source/util.c
-index 6fff179..41c624c 100644
---- a/source/util.c
-+++ b/source/util.c
-@@ -266,7 +266,7 @@ void printTwice(char *mess) /* send info to terminal (stdout) and to log */
-
- void prompt(char *mess) /* Send message to user, await reply */
- {
-- fprintf(stdout, mess) ;
-+ fprintf(stdout, "%s", mess) ;
-
- while (fgets(terminp, MAXSTRING, stdin) != NULL) {
- if ((int)strlen(terminp) > 0)
-@@ -722,7 +722,7 @@ void start_record()
- int k ;
-
- rec_length = k = sprintf(record, "\n") ;
-- rec_length += sprintf(record+k, timestamp()) ;
-+ rec_length += sprintf(record+k, "%s", timestamp()) ;
- k = rec_length ;
-
- if ((cwd = getcwd(NULL, 120)) == NULL)
diff --git a/sci-chemistry/eden/files/eden-5.3-impl-dec.patch b/sci-chemistry/eden/files/eden-5.3-impl-dec.patch
deleted file mode 100644
index af67508d090e..000000000000
--- a/sci-chemistry/eden/files/eden-5.3-impl-dec.patch
+++ /dev/null
@@ -1,28 +0,0 @@
- source/fbyteswap.c | 1 +
- source/util.c | 1 +
- 2 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/source/fbyteswap.c b/source/fbyteswap.c
-index 83015b9..c9033c3 100644
---- a/source/fbyteswap.c
-+++ b/source/fbyteswap.c
-@@ -39,6 +39,7 @@ and shall not be used for advertising or product endorsement purposes.
-
- #include <stdio.h>
- #include <fcntl.h>
-+#include <unistd.h>
- #include <sys/stat.h>
- #include <sys/types.h>
- void byteswap();
-diff --git a/source/util.c b/source/util.c
-index 6fff179..ca7a957 100644
---- a/source/util.c
-+++ b/source/util.c
-@@ -89,6 +89,7 @@ and shall not be used for advertising or product endorsement purposes.
-
- *******************************************************************************/
- #include <sys/time.h> /* ... for picking up date & time */
-+#include <time.h>
- #include <signal.h> /* ... for capturing kill */
- #include "util.h"
-
diff --git a/sci-chemistry/eden/files/makefile-fixes.patch b/sci-chemistry/eden/files/makefile-fixes.patch
deleted file mode 100644
index 4cfff3f515df..000000000000
--- a/sci-chemistry/eden/files/makefile-fixes.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -ur eden.orig/source/Makefile eden/source/Makefile
---- eden.orig/source/Makefile 2004-10-18 10:40:03.000000000 -0700
-+++ eden/source/Makefile 2005-12-15 22:32:45.000000000 -0800
-@@ -78,8 +78,10 @@
- #CFLAGS = -Wall -pipe -marchi686 -pedantic -gdwarf-2 -g3
- #CFLAGS = -Wall -O3 -march=i686
- ifneq ($(FFTW),/usr/local)
-+ifneq ($(FFTW),/usr)
- CFLAGS += -I$(INC)
- endif
-+endif
-
- # NOTE:
- # DOUBLESWITCH = ON for double precision;
-@@ -129,8 +131,8 @@
- mv fbyteswap $(BIN)
- mv eden $(BIN)/$(TARGET)
- chmod 751 $(BIN)/$(TARGET)
-- chmod +x mkeden.csh
-- ./mkeden.csh $(BIN) $(BIN)/$(TARGET)
-+# chmod +x mkeden.csh
-+# ./mkeden.csh $(BIN) $(BIN)/$(TARGET)
-
- dist: clean
- cd ../..; tar -cvf eden_$(VERSION).tar --exclude CVS --exclude \#\*\# --exclude \*~ --exclude Misc --exclude .\* eden; gzip -f eden_$(VERSION).tar
diff --git a/sci-chemistry/eden/metadata.xml b/sci-chemistry/eden/metadata.xml
deleted file mode 100644
index 6113635247f3..000000000000
--- a/sci-chemistry/eden/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
- <use>
- <flag name="double-precision">More precise calculations at the expense of
- speed</flag>
- </use>
-</pkgmetadata>