summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/vaal/files/vaal-1.2-respect-flags.patch')
-rw-r--r--sci-biology/vaal/files/vaal-1.2-respect-flags.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-biology/vaal/files/vaal-1.2-respect-flags.patch b/sci-biology/vaal/files/vaal-1.2-respect-flags.patch
new file mode 100644
index 000000000000..d3420556b608
--- /dev/null
+++ b/sci-biology/vaal/files/vaal-1.2-respect-flags.patch
@@ -0,0 +1,60 @@
+--- VAAL.orig/Makefile.in 2009-04-02 21:43:42.000000000 +0200
++++ VAAL/Makefile.in 2010-02-14 14:20:26.222370302 +0100
+@@ -161,12 +161,16 @@
+ COMPILER = @CC@
+ CPLUSPLUS = @CXX@
+
++CFLAGS = @CFLAGS@
++CXXFLAGS = @CXXFLAGS@
++LDFLAGS = @LDFLAGS@
++
+ # QUIET=yes causes the compiler to be less verbose about warnings.
+ QUIET = no
+
+ # DEBUG=yes forces out-of-date executables to be built with symbolic
+ # debugging information. Any other value is ignored.
+-DEBUG = yes
++DEBUG = no
+
+ # OPTIM=<compiler optimization> forces user-defined optimizations to be used,
+ # rather than the compiler-specific default.
+@@ -174,7 +178,7 @@
+ # If OPTIM=none, then no optimization is used.
+ # If unset, defaults are used.
+ # -fno-exceptions
+-OPTIM =
++OPTIM = none
+
+ # PROFILE=yes builds sampled-profiling (i.e. gprof) executables. Any other
+ # value is ignored.
+@@ -317,6 +321,7 @@
+ # Setup final compilation options:
+
+ CPP_OPTIONS = \
++ $(CXXFLAGS) \
+ $(SYS_WARN) \
+ $(SYS_OPT) \
+ $(SYS_DEBUG) \
+@@ -328,6 +333,7 @@
+ @INCLUDES@
+
+ LINK_OPTIONS = \
++ $(LDFLAGS) \
+ $(SYS_DEBUG) \
+ $(SYS_LINK) \
+ $(OMP_LINK) \
+@@ -406,12 +406,12 @@
+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
+
+ checkLock: $(SRC)/util/checkLock.cc
+- $(CPLUSPLUS) $(SRC)/util/checkLock.cc -o $(BIN)/checkLock
++ $(CPLUSPLUS) $(CXXFLAGS) $(SRC)/util/checkLock.cc $(LDFLAGS) -o $(BIN)/checkLock
+
+ random/Random.o: random/Random.cc
+ @ mkdir -p $(OBJ)/${@D}
+ cp $(SRC)/random/Random.cc $(SRC)/random/Random.c
+- $(CC) $(SYS_LANG) -c $(SRC)/random/Random.cc -w -Drandom=randomx -Dsrandom=srandomx -o $(OBJ)/random/Random.o
++ $(CC) $(CFLAGS) $(SYS_LANG) -c $(SRC)/random/Random.cc -w -Drandom=randomx -Dsrandom=srandomx -o $(OBJ)/random/Random.o
+ rm $(SRC)/random/Random.c
+
+ MemTracker.o: MemTracker.cc