summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/sim4')
-rw-r--r--sci-biology/sim4/Manifest1
-rw-r--r--sci-biology/sim4/metadata.xml21
-rw-r--r--sci-biology/sim4/sim4-20030921-r1.ebuild26
-rw-r--r--sci-biology/sim4/sim4-20030921.ebuild19
4 files changed, 67 insertions, 0 deletions
diff --git a/sci-biology/sim4/Manifest b/sci-biology/sim4/Manifest
new file mode 100644
index 000000000000..f2a25200b895
--- /dev/null
+++ b/sci-biology/sim4/Manifest
@@ -0,0 +1 @@
+DIST sim4.tar.gz 60814 RMD160 5acad71daa94893025a21b73b416dd3903078be5 SHA1 11a9170ea03990268d409056084415d725c6290b SHA256 0d65166c1d1951e1d0b83e5d221f23f07462b9d8c46ea0d0569f66e35a5229ee
diff --git a/sci-biology/sim4/metadata.xml b/sci-biology/sim4/metadata.xml
new file mode 100644
index 000000000000..ea9731279003
--- /dev/null
+++ b/sci-biology/sim4/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ sim4 is a similarity-based tool for aligning an expressed DNA sequence
+ (EST, cDNA, mRNA) with a genomic sequence for the gene. It also detects
+ end matches when the two input sequences overlap at one end (i.e., the
+ start of one sequence overlaps the end of the other).sim4 employs a
+ blast-based technique to first determine the basic matching blocks
+ representing the "exon cores". In this first stage, it detects all
+ possible exact matches of W-mers (i.e., DNA words of size W) between
+ the two sequences and extends them to maximal scoring gap-free
+ segments. In the second stage, the exon cores are extended into the
+ adjacent as-yet-unmatched fragments using greedy alignment algorithms,
+ and heuristics are used to favor configurations that conform to the
+ splice-site recognition signals (GT-AG, CT-AC). If necessary, the
+ process is repeated with less stringent parameters on the unmatched
+ fragments.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/sim4/sim4-20030921-r1.ebuild b/sci-biology/sim4/sim4-20030921-r1.ebuild
new file mode 100644
index 000000000000..178bf92ab5da
--- /dev/null
+++ b/sci-biology/sim4/sim4-20030921-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A program to align cDNA and genomic DNA"
+HOMEPAGE="http://globin.cse.psu.edu/html/docs/sim4.html"
+SRC_URI="http://globin.cse.psu.edu/ftp/dist/sim4/sim4.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}.2003-09-21
+
+src_compile() {
+ echo "$(tc-getCC) -o ${PN} ${LDFLAGS} -I. ${CFLAGS} *.c -lm"
+ $(tc-getCC) -o ${PN} ${LDFLAGS} -I. ${CFLAGS} *.c -lm || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc README.* VERSION || die
+}
diff --git a/sci-biology/sim4/sim4-20030921.ebuild b/sci-biology/sim4/sim4-20030921.ebuild
new file mode 100644
index 000000000000..12d5231aa120
--- /dev/null
+++ b/sci-biology/sim4/sim4-20030921.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="A program to align cDNA and genomic DNA"
+HOMEPAGE="http://globin.cse.psu.edu/html/docs/sim4.html"
+SRC_URI="http://globin.cse.psu.edu/ftp/dist/sim4/sim4.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+S="${WORKDIR}/${PN}.2003-09-21"
+
+src_install() {
+ dobin sim4 || die
+ dodoc README.psublast README.sim4 VERSION || die
+}