summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/ratproxy/ratproxy-1.58.ebuild')
-rw-r--r--net-proxy/ratproxy/ratproxy-1.58.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/net-proxy/ratproxy/ratproxy-1.58.ebuild b/net-proxy/ratproxy/ratproxy-1.58.ebuild
deleted file mode 100644
index dee8b368423c..000000000000
--- a/net-proxy/ratproxy/ratproxy-1.58.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A semi-automated, largely passive web application security audit tool"
-HOMEPAGE="https://code.google.com/p/ratproxy/"
-SRC_URI="https://ratproxy.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-libs/openssl"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "s:keyfile\.pem:/usr/share/${PN}/&:" ssl.c
- sed -r -i -e "s:(ratproxy-back\.png|messages\.list):/usr/share/${PN}/&:" ratproxy-report.sh
- epatch "${FILESDIR}"/${PN}-Makefile.patch
-}
-
-src_compile() {
- tc-export CC
-
- emake || die "emake failed"
-}
-
-src_install() {
- dobin ${PN}-report.sh || die "install failed"
- dobin ${PN} || die "install failed"
- dodoc doc/{README,TODO}
- insinto /usr/share/${PN}
- doins keyfile.pem ratproxy-back.png messages.list
-}