summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/syncthing/syncthing-0.12.24.ebuild')
-rw-r--r--net-p2p/syncthing/syncthing-0.12.24.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/net-p2p/syncthing/syncthing-0.12.24.ebuild b/net-p2p/syncthing/syncthing-0.12.24.ebuild
deleted file mode 100644
index 4aef0ac1d703..000000000000
--- a/net-p2p/syncthing/syncthing-0.12.24.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-EGO_PN="github.com/syncthing/syncthing"
-EGIT_COMMIT=v${PV}
-
-inherit golang-vcs-snapshot systemd user
-
-DESCRIPTION="Open Source Continuous File Synchronization"
-HOMEPAGE="https://syncthing.net"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~arm"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
-}
-
-src_compile() {
- export GOPATH="${S}:$(get_golibdir_gopath)"
- cd src/${EGO_PN}
- go run build.go -version "v${PV}" -no-upgrade || die "build failed"
-}
-
-src_test() {
- cd src/${EGO_PN}
- go run build.go test || die "test failed"
-}
-
-src_install() {
- cd src/${EGO_PN}
- doman man/*.[157]
- dobin bin/*
- dodoc README.md AUTHORS CONTRIBUTING.md
- systemd_dounit "${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}@.service \
- "${S}"/src/${EGO_PN}/etc/linux-systemd/system/${PN}-resume.service
- systemd_douserunit "${S}"/src/${EGO_PN}/etc/linux-systemd/user/${PN}.service
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
- newinitd "${FILESDIR}/${PN}.initd" ${PN}
- keepdir /var/{lib,log}/${PN}
- fowners ${PN}:${PN} /var/{lib,log}/${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotate" ${PN}
-}