summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/Manifest2
-rw-r--r--net-libs/gloox/gloox-1.0.13.ebuild48
-rw-r--r--net-libs/gloox/gloox-1.0.9.ebuild37
-rw-r--r--net-libs/gloox/metadata.xml5
4 files changed, 92 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
new file mode 100644
index 000000000000..815e0641563c
--- /dev/null
+++ b/net-libs/gloox/Manifest
@@ -0,0 +1,2 @@
+DIST gloox-1.0.13.tar.bz2 675842 SHA256 4d9f1eeac97c6563dde11d4bdba346a025ef27908b088b47b5c8d3d03df6ea8a SHA512 9f9773a5c3d2ae8a4eec6e8365c8578c089004d0f5101c2e8a8bf96ac8e8b6a08cf4e92f93afb8d07af0e8cc2c238c12f4f8df75a81c2a06dfb039c1d4ae850a WHIRLPOOL 772b18a22acff536abb378a4307c6dcb3b9b35b231d061f05b22d5cb260d8da3c0356bdbca0a8cac9feab0fbc9124bc41472b91a335215291e1e66a9184ccc78
+DIST gloox-1.0.9.tar.bz2 670206 SHA256 143dd50e1edc4eb1d304fa28bdd6ab9e53b60c37c1726dd0e34c06c51f9a453e SHA512 a3fa7acc76fdca0421030e71b6a13ca0b04589946df2a781609f1bddae5329299d68ce99a4a94a0760206b112759636379ce67d220422b99302fc799964bfa22 WHIRLPOOL 414eb34fa3ec11ae929f84198d95ed0da9de0739655ae1188ac3eb03998de5cecb9c165ad284496b405b49126236b628dc5b4579e855b10377add145fabb63b1
diff --git a/net-libs/gloox/gloox-1.0.13.ebuild b/net-libs/gloox/gloox-1.0.13.ebuild
new file mode 100644
index 000000000000..5bc18fc75472
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/13"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~ia64 ~sparc ~x86"
+IUSE="debug gnutls idn ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ econf \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
+ $(use_with idn libidn) \
+ $(use_with gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with test tests) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-libs/gloox/gloox-1.0.9.ebuild b/net-libs/gloox/gloox-1.0.9.ebuild
new file mode 100644
index 000000000000..51c93c5f4f77
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${P/_/-}
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ~ppc64 sparc x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
diff --git a/net-libs/gloox/metadata.xml b/net-libs/gloox/metadata.xml
new file mode 100644
index 000000000000..3e2b4181f5be
--- /dev/null
+++ b/net-libs/gloox/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+</pkgmetadata>