summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/choqok/choqok-1.5.ebuild')
-rw-r--r--net-im/choqok/choqok-1.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-im/choqok/choqok-1.5.ebuild b/net-im/choqok/choqok-1.5.ebuild
new file mode 100644
index 000000000000..e26f35e3cde9
--- /dev/null
+++ b/net-im/choqok/choqok-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fa fi fr ga gl
+hr hu is it ja km lt mr ms nb nds nl pa pl pt pt_BR ro ru sk sl sq sv tr ug
+uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Free/Open Source micro-blogging client for KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 ~ppc x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+IUSE="ayatana debug telepathy"
+
+RDEPEND="
+ dev-libs/libattica
+ dev-libs/qjson
+ >=dev-libs/qoauth-1.0.1
+ ayatana? ( dev-libs/libindicate-qt )
+ telepathy? ( net-libs/telepathy-qt[qt4] )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS README TODO changelog )
+
+src_prepare(){
+ local mycmakeargs=(
+ $(cmake-utils_use !ayatana QTINDICATE_DISABLE)
+ $(cmake-utils_use_find_package telepathy TelepathyQt4)
+ )
+
+ kde4-base_src_prepare
+}