summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/uftpd/uftpd-2.5.ebuild')
-rw-r--r--net-ftp/uftpd/uftpd-2.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-ftp/uftpd/uftpd-2.5.ebuild b/net-ftp/uftpd/uftpd-2.5.ebuild
new file mode 100644
index 000000000000..69e14845f657
--- /dev/null
+++ b/net-ftp/uftpd/uftpd-2.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The no nonsense TFTP/FTP server"
+HOMEPAGE="https://github.com/troglobit/uftpd"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ !net-misc/uftp
+ !net-ftp/atftp
+ dev-libs/libite
+ dev-libs/libuev"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install doc_DATA=README.md
+}