summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/nsd/nsd-4.3.4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-dns/nsd/nsd-4.3.4.ebuild b/net-dns/nsd/nsd-4.3.4.ebuild
index 26d8ed0e7695..46801d6b5f08 100644
--- a/net-dns/nsd/nsd-4.3.4.ebuild
+++ b/net-dns/nsd/nsd-4.3.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit systemd
+inherit autotools systemd
# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
MY_PV="${PV/_beta/b}"
@@ -48,6 +48,13 @@ PATCHES=(
"${FILESDIR}"/nsd_munin_.patch
)
+src_prepare() {
+ default
+ # Required to get correct pkg-config macros with USE="systemd"
+ # see bugs #663618 and #758050
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
--enable-largefile