summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/kodi-pvr-mythtv')
-rw-r--r--media-plugins/kodi-pvr-mythtv/Manifest1
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild37
-rw-r--r--media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild11
3 files changed, 44 insertions, 5 deletions
diff --git a/media-plugins/kodi-pvr-mythtv/Manifest b/media-plugins/kodi-pvr-mythtv/Manifest
index 43d8c09afca8..f2b2b3b05214 100644
--- a/media-plugins/kodi-pvr-mythtv/Manifest
+++ b/media-plugins/kodi-pvr-mythtv/Manifest
@@ -1 +1,2 @@
DIST kodi-pvr-mythtv-4.15.3.tar.gz 650217 BLAKE2B ddc6b11039bd8e5e6b46331030909063e127f681f4059e604734644a3159c10f10c3dbed770ba8a58bb5ea3b7e543dfba042b28f347c842d963d7966e35cad32 SHA512 1171f4e6a05878660795b585185d35707ef713e310f3508e7fb3327caf79feb6a941e4b4f4d9f2331ef13492c141a4d36157547e350642eee900f3fad1d46b55
+DIST kodi-pvr-mythtv-5.8.14.tar.gz 696544 BLAKE2B a80b84d6c3aa2244d68f7c7ffca16b17e5942239a55a67e059a6a016f9970f7c8ca65071a6b498dbae8c0addea95349f49f27a7e7ce8888a1d9a2fd5294a8d0e SHA512 44630a944eeee7cb97de91183b560beef00d686148880ebba51063fe1f320bd43cd2c9a89061c49fbf8c5e038ac5d6788440fc948ba46ca130e8bd8a980dff97
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild
new file mode 100644
index 000000000000..05d2594341ea
--- /dev/null
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-5.8.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="MythTV PVR for Kodi"
+HOMEPAGE="https://github.com/janbar/pvr.mythtv"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/janbar/pvr.mythtv.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ sys-libs/zlib
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
index 4a54f66b3130..d0a95543a96a 100644
--- a/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
+++ b/media-plugins/kodi-pvr-mythtv/kodi-pvr-mythtv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,9 +16,10 @@ case ${PV} in
inherit git-r3
;;
*)
+ CODENAME="Leia"
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/pvr.mythtv-${PV}"
+ SRC_URI="https://github.com/janbar/pvr.mythtv/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.mythtv-${PV}-${CODENAME}"
;;
esac
@@ -28,8 +29,8 @@ IUSE=""
DEPEND="
sys-libs/zlib
- =media-tv/kodi-9999
- =media-libs/kodi-platform-9999
+ ~media-tv/kodi-9999
+ ~media-libs/kodi-platform-9999
"
RDEPEND="
${DEPEND}