summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/dfarc/Manifest1
-rw-r--r--games-util/dfarc/dfarc-3.14.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/games-util/dfarc/Manifest b/games-util/dfarc/Manifest
index 280d7b77d289..1b0c76757a47 100644
--- a/games-util/dfarc/Manifest
+++ b/games-util/dfarc/Manifest
@@ -1 +1,2 @@
DIST dfarc-3.12.tar.gz 329925 BLAKE2B ebebfdf42fbd8bcc53696777f5fb06a54635e269dafb59c888990250343e0bca0b20d46b051e753b047f008061ef74070456d83ee72eb37018a2bc1b386d1c9f SHA512 e87e89e67e383c3d25a6620edc38c6ab6f90b9df52b84d6e6de20af1ac3b50588b3037575f2f89a14c90c14151053c08a7bb97143f24471e33326f3f2d2574ab
+DIST dfarc-3.14.tar.gz 336910 BLAKE2B 50f0ad1af2d91a562ba6a7b1e0e5e1821c900fe8ab3cf48f3585ca10ea12d9f7e3125ae85bc2e31c1539bf13d5a950e30a467b05259a7df6e2bda35544820933 SHA512 536c1cb5d1c8bf7012920e39d69fafbb790da78acb89a18f8ab1a3ad985220c74da61adda238e39395b4d7fd8fc62894fb5579691b744fe17600a8fccabc3c13
diff --git a/games-util/dfarc/dfarc-3.14.ebuild b/games-util/dfarc/dfarc-3.14.ebuild
new file mode 100644
index 000000000000..96118b386c92
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+inherit eutils gnome2-utils wxwidgets xdg
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.freedink.org/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ nls? ( >=dev-util/intltool-0.31 )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.12-nowindres.patch )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --disable-desktopfiles
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}