summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-9999-r1.ebuild')
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 906428738da6..69b91dbc3a74 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation