summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/uncrustify/uncrustify-9999.ebuild')
-rw-r--r--dev-util/uncrustify/uncrustify-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-util/uncrustify/uncrustify-9999.ebuild b/dev-util/uncrustify/uncrustify-9999.ebuild
index cf696e3ae8b0..9de89d8f4c74 100644
--- a/dev-util/uncrustify/uncrustify-9999.ebuild
+++ b/dev-util/uncrustify/uncrustify-9999.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ $PV == *9999* ]]; then
- EGIT_REPO_URI="git://github.com/bengardner/uncrustify.git
- https://github.com/bengardner/uncrustify.git"
+ EGIT_REPO_URI="git://github.com/uncrustify/uncrustify.git
+ https://github.com/uncrustify/uncrustify.git"
KEYWORDS=""
SRC_URI=""
- inherit git-r3
+ inherit git-r3 autotools
else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/uncrustify/${PN}/archive/${P}.tar.gz"
+ S=${WORKDIR}/uncrustify-${P}
fi
PYTHON_COMPAT=( python2_7 )
@@ -28,6 +29,13 @@ IUSE="test"
DEPEND="test? ( ${PYTHON_DEPS} )"
+src_prepare() {
+ if [[ ${PV} == *9999* ]] ; then
+ eautoreconf
+ fi
+ default
+}
+
python_test() {
cd tests
${EPYTHON} run_tests.py || die "tests failed"