summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/plasmate/plasmate-1.0.ebuild')
-rw-r--r--dev-util/plasmate/plasmate-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/plasmate/plasmate-1.0.ebuild b/dev-util/plasmate/plasmate-1.0.ebuild
new file mode 100644
index 000000000000..6945310fa1c3
--- /dev/null
+++ b/dev-util/plasmate/plasmate-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="IDE for writing KDE Plasma/KWin components (themes, Plasmoids, runners, data engines)"
+HOMEPAGE="https://projects.kde.org/projects/extragear/sdk/plasmate"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ app-crypt/gpgme
+ dev-libs/libattica
+ dev-libs/soprano
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdeapps_dep knewstuff)
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"