summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/Manifest4
-rw-r--r--dev-util/mdds/files/mdds-0.11.2-include_algorithm_unconditionally.patch33
-rw-r--r--dev-util/mdds/mdds-0.10.3.ebuild34
-rw-r--r--dev-util/mdds/mdds-0.11.2-r1.ebuild38
-rw-r--r--dev-util/mdds/mdds-0.12.0.ebuild34
-rw-r--r--dev-util/mdds/mdds-0.12.1.ebuild43
-rw-r--r--dev-util/mdds/mdds-9999.ebuild43
-rw-r--r--dev-util/mdds/metadata.xml8
8 files changed, 237 insertions, 0 deletions
diff --git a/dev-util/mdds/Manifest b/dev-util/mdds/Manifest
new file mode 100644
index 000000000000..cd58451961d3
--- /dev/null
+++ b/dev-util/mdds/Manifest
@@ -0,0 +1,4 @@
+DIST mdds_0.10.3.tar.bz2 151389 SHA256 db10932dbe7e9b5b9b3f513bc8165ab7e29c3bf75702b3c3cfff6956c521e0c2 SHA512 52be0fe4eedc8a44f61944e078d8f0d2490bfea27451c5d4772b6d46d71562702d3b90b34c5721d8bdf6de2ea32a4a9126e310614bb36e0d573c047dfc9f3fcb WHIRLPOOL 17a461cf01f286ccb0e8b351e627dc870db5676a3698cf99f1520b01562138a8d74fa99ccca901d81b5f354abf95ff35d2a7957a3bf2dae16d92aee12e62f8b1
+DIST mdds_0.11.2.tar.bz2 154444 SHA256 cd0a0dc8b35d6582efad6898546c86714eb058696ba26b0e7f8914faa002a5ab SHA512 b0e00d50be9b8319dabfe7e607849af27a52be9b46d770849b919444b905bf198d99edcefe1be15e6018b79839443b3a709fe22b84ac11e2267f02bec5139633 WHIRLPOOL a505c4b746c7ffefe3ea74fd0eb7c2ae46b4c598e1136cf9e9cfe44a4c48db2bb1b84528a5f0a86cc1b7a5c9d5b7d82522bd7836ed5e4de61d9664a863e1b014
+DIST mdds_0.12.0.tar.bz2 152285 SHA256 2a22de23ca828886625120e9d40fccd6333458a1934a13d2c982b6f9403e5981 SHA512 462f6e3701eb7cce872ce0a76d826886eedccf5ca20293d03744b6d6d5ff1ef16770c6abce1c9118829e252e90783e206d281006d0d4e7e9b328ed9ae37264c1 WHIRLPOOL f86314644d80ae1b75a4cc1af6ebc4a3df3b65eac4244abc0fbf69893020509abae3be7e758d90a07eafffb866d67dcb75968b38a411e747d7f361a7d2905f0b
+DIST mdds_0.12.1.tar.bz2 153265 SHA256 23565e9d7810a6ac30478833813db847f80e927b414a7be07b7cc03ed3aae83d SHA512 852f58e1f3c18aef78646c2bd6b34dc544fc06cba7ef6bda2a44fd5e681bf47bbf7389505061ddd81797b0bdf343e55f060397a1ccc582c73990bc74d36575a6 WHIRLPOOL d4f144e59806310c6a719600b88b4a0d9816d94dd48298458f459bc696b97ab4e82152ac7e4d9dcb3e8aa66a5fd67377c82c6bb161bf93135e0c6b73d01fb02e
diff --git a/dev-util/mdds/files/mdds-0.11.2-include_algorithm_unconditionally.patch b/dev-util/mdds/files/mdds-0.11.2-include_algorithm_unconditionally.patch
new file mode 100644
index 000000000000..9b0f09705407
--- /dev/null
+++ b/dev-util/mdds/files/mdds-0.11.2-include_algorithm_unconditionally.patch
@@ -0,0 +1,33 @@
+From c45e0499dded11dc2aacea40b470ab1431ea535a Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Thu, 29 Jan 2015 10:04:56 +0100
+Subject: [PATCH] <algorithm> is needed unconditionally
+
+---
+ include/mdds/multi_type_vector_types.hpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/include/mdds/multi_type_vector_types.hpp b/include/mdds/multi_type_vector_types.hpp
+index db8d584..0a36333 100644
+--- a/include/mdds/multi_type_vector_types.hpp
++++ b/include/mdds/multi_type_vector_types.hpp
+@@ -32,6 +32,8 @@
+ #include "compat/unique_ptr.hpp"
+ #include "global.hpp"
+
++#include <algorithm>
++
+ #ifdef MDDS_MULTI_TYPE_VECTOR_USE_DEQUE
+ #include <deque>
+ #else
+@@ -40,7 +42,6 @@
+ #include <boost/noncopyable.hpp>
+
+ #if defined(MDDS_UNIT_TEST) || defined (MDDS_MULTI_TYPE_VECTOR_DEBUG)
+-#include <algorithm>
+ #include <iostream>
+ #include <sstream>
+ using std::cout;
+--
+2.2.2
+
diff --git a/dev-util/mdds/mdds-0.10.3.ebuild b/dev-util/mdds/mdds-0.10.3.ebuild
new file mode 100644
index 000000000000..cdccda48b71f
--- /dev/null
+++ b/dev-util/mdds/mdds-0.10.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="http://code.google.com/p/multidimalgorithm/"
+SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="<dev-libs/boost-1.57.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/-/_}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-0.11.2-r1.ebuild b/dev-util/mdds/mdds-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..6bb1766c2b6e
--- /dev/null
+++ b/dev-util/mdds/mdds-0.11.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="http://code.google.com/p/multidimalgorithm/"
+SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/-/_}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-include_algorithm_unconditionally.patch"
+}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-0.12.0.ebuild b/dev-util/mdds/mdds-0.12.0.ebuild
new file mode 100644
index 000000000000..f3b70fdb805d
--- /dev/null
+++ b/dev-util/mdds/mdds-0.12.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="http://code.google.com/p/multidimalgorithm/"
+SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/-/_}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-0.12.1.ebuild b/dev-util/mdds/mdds-0.12.1.ebuild
new file mode 100644
index 000000000000..295fefb5ae43
--- /dev/null
+++ b/dev-util/mdds/mdds-0.12.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+
+inherit eutils toolchain-funcs ${GITECLASS}
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == 9999 ]] || S=${WORKDIR}/${P/-/_}
+
+src_prepare(){
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
new file mode 100644
index 000000000000..e0db9959c3b9
--- /dev/null
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+
+inherit eutils toolchain-funcs ${GITECLASS}
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == 9999 ]] || S=${WORKDIR}/${P/-/_}
+
+src_prepare(){
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-hash-container=boost \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/metadata.xml b/dev-util/mdds/metadata.xml
new file mode 100644
index 000000000000..4409d6128912
--- /dev/null
+++ b/dev-util/mdds/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <upstream>
+ <remote-id type="google-code">multidimalgorithm</remote-id>
+ </upstream>
+</pkgmetadata>