summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/include-what-you-use/include-what-you-use-3.3-r1.ebuild')
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-3.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-3.3-r1.ebuild b/dev-util/include-what-you-use/include-what-you-use-3.3-r1.ebuild
new file mode 100644
index 000000000000..5480dbdc8c01
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-3.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="find unused include directives in C/C++ programs"
+HOMEPAGE="https://code.google.com/p/include-what-you-use/"
+# picked from google drive
+SRC_URI="http://dev.gentoo.org/~slyfox/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sys-devel/llvm-3.3*
+ =sys-devel/clang-3.3*"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-issue-110-elaboration.patch
+ epatch_user
+}
+
+src_configure() {
+ append-ldflags -L$(llvm-config --libdir)
+
+ local mycmakeargs=(
+ -DLLVM_PATH=$(llvm-config --libdir)
+ )
+ cmake-utils_src_configure
+}