summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/herdtools7/herdtools7-7.47.ebuild')
-rw-r--r--dev-util/herdtools7/herdtools7-7.47.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/herdtools7/herdtools7-7.47.ebuild b/dev-util/herdtools7/herdtools7-7.47.ebuild
new file mode 100644
index 000000000000..f4e8a84c5b07
--- /dev/null
+++ b/dev-util/herdtools7/herdtools7-7.47.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="The Herd toolsuite to deal with .cat memory models"
+HOMEPAGE="http://diy.inria.fr/sources/index.html"
+SRC_URI="https://github.com/herd/herdtools7/archive/${PV}.tar.gz"
+
+LICENSE="CeCILL-B"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/ocamlbuild"
+RDEPEND=">=dev-lang/ocaml-4.01.0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-mkdir.patch"
+)
+
+src_compile() {
+ ./build.sh /usr
+}
+
+src_install() {
+ ./install.sh "${ED}/usr"
+}