summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/public_suffix/public_suffix-2.0.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/public_suffix/public_suffix-2.0.3-r1.ebuild b/dev-ruby/public_suffix/public_suffix-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..87beea343286
--- /dev/null
+++ b/dev-ruby/public_suffix/public_suffix-2.0.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse and decompose a domain name into top level domain, domain and subdomains"
+HOMEPAGE="https://simonecarletti.com/code/publicsuffix-ruby/"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i -e '/rubocop/I s:^:#:' Rakefile || die
+ sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
+}