summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.9.1.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.9.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.9.1.ebuild b/dev-ruby/simplecov/simplecov-0.9.1.ebuild
deleted file mode 100644
index 5279fb7ab785..000000000000
--- a/dev-ruby/simplecov/simplecov-0.9.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Code coverage with a configuration library and automatic merging of coverage across test suites"
-HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
-LICENSE="MIT"
-
-KEYWORDS="~amd64"
-SLOT="0.8"
-IUSE="doc"
-
-ruby_add_rdepend ">=dev-ruby/multi_json-1.0
- dev-ruby/simplecov-html:0.8
- >=dev-ruby/docile-1.1.0"
-
-ruby_add_bdepend "test? (
- dev-ruby/rspec
- dev-ruby/shoulda
- dev-ruby/test-unit:2
- dev-util/cucumber
- dev-util/aruba
- dev-ruby/capybara
-)"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' test/helper.rb features/support/env.rb || die
-
- # Avoid currently failing test, needs further research.
- rm test/test_merge_helpers.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib test/test_*.rb
-
-# ${RUBY} -S cucumber features || die
-}