summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashie/hashie-3.4.2.ebuild')
-rw-r--r--dev-ruby/hashie/hashie-3.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/hashie/hashie-3.4.2.ebuild b/dev-ruby/hashie/hashie-3.4.2.ebuild
new file mode 100644
index 000000000000..d65b458c1fdd
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' -i spec/spec_helper.rb || die
+}