summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/urllib3-1.25.8.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/urllib3/urllib3-1.25.8.ebuild b/dev-python/urllib3/urllib3-1.25.8.ebuild
index 66703bcc3a1f..3279a2e0cbe0 100644
--- a/dev-python/urllib3/urllib3-1.25.8.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.8.ebuild
@@ -53,6 +53,11 @@ python_prepare_all() {
-i test/with_dummyserver/test_https.py || die
sed -e 's:test_https_proxy_.*timeout:_&:' \
-i test/with_dummyserver/test_proxy_poolmanager.py || die
+ # tests failing if 'localhost.' cannot be resolved
+ sed -e 's:test_dotted_fqdn:_&:' \
+ -i test/with_dummyserver/test_https.py || die
+ sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
+ -i test/with_dummyserver/test_socketlevel.py || die
# no clue why those fail, might be tornado's fault, might be just
# very flaky
sed -e 's:test_client_no_intermediate:_&:' \