summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/pylint-3.0.2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pylint/pylint-3.0.2.ebuild b/dev-python/pylint/pylint-3.0.2.ebuild
index 9f66ca157073..45c911979549 100644
--- a/dev-python/pylint/pylint-3.0.2.ebuild
+++ b/dev-python/pylint/pylint-3.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -44,7 +44,9 @@ RDEPEND="
"
BDEPEND="
test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
@@ -66,6 +68,15 @@ python_test() {
tests/benchmark/test_baseline_benchmarks.py
)
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # Requires GitPython
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
rm -rf pylint || die
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1