summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgspecial/pgspecial-1.11.7.ebuild')
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.7.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/pgspecial/pgspecial-1.11.7.ebuild b/dev-python/pgspecial/pgspecial-1.11.7.ebuild
deleted file mode 100644
index 114ed95d1ae7..000000000000
--- a/dev-python/pgspecial/pgspecial-1.11.7.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of postgres meta commands"
-HOMEPAGE="https://github.com/dbcli/pgspecial"
-SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
- >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # tests/test_special.py require local postgres instance
- pytest -vv tests/test_internal.py || die
-}