summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-1.5-r1.ebuild')
-rw-r--r--dev-python/keyring/keyring-1.5-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/keyring/keyring-1.5-r1.ebuild b/dev-python/keyring/keyring-1.5-r1.ebuild
deleted file mode 100644
index 4ce5c23800a4..000000000000
--- a/dev-python/keyring/keyring-1.5-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 pypy )
-#tests restricted due to unpackaged dependancies
-RESTRICT="test"
-
-inherit distutils-r1
-DESCRIPTION="Provides access to the system keyring service"
-HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
-SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
-
-LICENSE="PSF-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- dev-python/pytest-runner[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-PATCHES=(
-)
-# "${FILESDIR}/setup-1.0.patch"
-
-python_test() {
- # test_backend.py and test_core.py access keyring backends
- # which may spawn password prompts and do other damage.
-
- # XXX: leave out the harmless tests (dummy backends?)
-
- for t in test_{cli,util}.py; do
- "${PYTHON}" "${BUILD_DIR}"/lib/${PN}/tests/${t} \
- || die "${t} fails with ${EPYTHON}"
- done
-}