summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/doit-py/doit-py-0.4.0-r2.ebuild')
-rw-r--r--dev-python/doit-py/doit-py-0.4.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/doit-py/doit-py-0.4.0-r2.ebuild b/dev-python/doit-py/doit-py-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..94b95b479f33
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.4.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="https://pythonhosted.org/doit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ app-text/hunspell
+ )"
+RDEPEND="
+ dev-python/configclass[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest