summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-04-22 14:28:55 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-16 15:59:40 +0300
commit84a05cae594ef12b78257f5bafd4d3b5724a7ed6 (patch)
tree0bd14cca9333c6e0af582ca50fcd3160fcf2003b /dev-python/doit-py/doit-py-0.4.0-r2.ebuild
parentmedia-sound/strawberry: Removed old (diff)
downloadgentoo-84a05cae594ef12b78257f5bafd4d3b5724a7ed6.tar.gz
gentoo-84a05cae594ef12b78257f5bafd4d3b5724a7ed6.tar.bz2
gentoo-84a05cae594ef12b78257f5bafd4d3b5724a7ed6.zip
dev-python/doit-py: add python3_7 to PYTHON_COMPAT
Rewrite doc and test phases to use distutils_enable_sphinx and distutils_enable_tests. Closes: https://bugs.gentoo.org/718636 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/doit-py/doit-py-0.4.0-r2.ebuild')
-rw-r--r--dev-python/doit-py/doit-py-0.4.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/doit-py/doit-py-0.4.0-r2.ebuild b/dev-python/doit-py/doit-py-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..94b95b479f33
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.4.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="https://pythonhosted.org/doit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ app-text/hunspell
+ )"
+RDEPEND="
+ dev-python/configclass[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest