summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/testpack')
-rw-r--r--dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch13
-rw-r--r--dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch2
-rw-r--r--dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild1
3 files changed, 15 insertions, 1 deletions
diff --git a/dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch b/dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch
new file mode 100644
index 000000000000..599615a8e5fb
--- /dev/null
+++ b/dev-haskell/testpack/files/testpack-2.1.3.0-HUnit-1.3.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Test/HUnit/Tools.hs b/src/Test/HUnit/Tools.hs
+index a24a510..6b8a25e 100644
+--- a/src/Test/HUnit/Tools.hs
++++ b/src/Test/HUnit/Tools.hs
+@@ -97,3 +97,7 @@ runVerbTestText (HU.PutText put us) t = do
+ reportFailure = reportProblem "Failure:" "Failure in: "
+- reportProblem p0 p1 msg ss us = put line True us
++ reportProblem p0 p1
++#if MIN_VERSION_HUnit(1,3,0)
++ _loc
++#endif
++ msg ss us = put line True us
+ where line = "### " ++ kind ++ path' ++ '\n' : msg
diff --git a/dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch b/dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch
index 1bc9537f5d2a..4ca1848888c6 100644
--- a/dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch
+++ b/dev-haskell/testpack/files/testpack-2.1.3.0-qc28.patch
@@ -116,7 +116,7 @@ index 712c9bf..506686f 100644
- reason = "Result: expected " ++ show expected ++ ", got " ++ show actual,
- stamp = [], callbacks = []}
-
-+ P.result { P.ok = Just (expected == actual)
++ P.failed { P.ok = Just (expected == actual)
+ , P.reason = "Result: expected " ++ show expected ++ ", got " ++ show actual
+ }
{- | Like '@=?', but with args in a different order. -}
diff --git a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
index a3fa62e101e4..97ca628aef48 100644
--- a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
+++ b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
@@ -30,4 +30,5 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-qc28.patch
+ epatch "${FILESDIR}"/${P}-HUnit-1.3.patch
}