summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/sandi')
-rw-r--r--dev-haskell/sandi/Manifest1
-rw-r--r--dev-haskell/sandi/metadata.xml11
-rw-r--r--dev-haskell/sandi/sandi-0.3.5.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/sandi/Manifest b/dev-haskell/sandi/Manifest
new file mode 100644
index 000000000000..bbc45c89ce2c
--- /dev/null
+++ b/dev-haskell/sandi/Manifest
@@ -0,0 +1 @@
+DIST sandi-0.3.5.tar.gz 18700 SHA256 856ed995bad4183a69f65c70a78c4be37cf614c906097ea126bae75ce08daea5 SHA512 0ba8f1cbb10097283a58a133c3e119335efd326f9a27a9178b424c5d0fac31a28dcd2167b17a7d8a934f638a1d98c41f4592184124387c37e37961db43f3b020 WHIRLPOOL e953262ea2e4a0d0074bb420a7a57804ec7e194b17205c3f07121171df98459fec0d6ff0a95b959c61b4981febdf54002231ad42a6b4cea6ff593cf675558c6f
diff --git a/dev-haskell/sandi/metadata.xml b/dev-haskell/sandi/metadata.xml
new file mode 100644
index 000000000000..6803ad614312
--- /dev/null
+++ b/dev-haskell/sandi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Reasonably fast data encoding library.
+ </longdescription>
+ <use>
+ <flag name="with-conduit">Build with conduit</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-haskell/sandi/sandi-0.3.5.ebuild b/dev-haskell/sandi/sandi-0.3.5.ebuild
new file mode 100644
index 000000000000..a90cf763b31c
--- /dev/null
+++ b/dev-haskell/sandi/sandi-0.3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://hackage.haskell.org/package/sandi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+with-conduit"
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+ with-conduit? ( >=dev-haskell/conduit-1.2:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?] <dev-haskell/exceptions-0.9:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ dev-haskell/tasty-th )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag with-conduit with-conduit)
+}