summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gsl/gsl-0_pre20171105.ebuild')
-rw-r--r--dev-cpp/gsl/gsl-0_pre20171105.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/gsl/gsl-0_pre20171105.ebuild b/dev-cpp/gsl/gsl-0_pre20171105.ebuild
new file mode 100644
index 000000000000..78ac010145e7
--- /dev/null
+++ b/dev-cpp/gsl/gsl-0_pre20171105.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Guideline Support Library implementation by Microsoft"
+HOMEPAGE="https://github.com/Microsoft/GSL"
+SRC_URI="https://github.com/Microsoft/${PN}/tarball/d10ebc6555b627c9d1196076a78467e7be505987 -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# header only library
+RDEPEND=""
+DEPEND="test? ( >=dev-cpp/catch-1.11.0 )"
+
+src_configure() {
+ local mycmakeargs=( -DGSL_TEST=$(usex test) )
+ cmake-utils_src_configure
+}