summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/hd2u/files/hd2u-1.0.0-build.patch')
-rw-r--r--app-text/hd2u/files/hd2u-1.0.0-build.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/hd2u/files/hd2u-1.0.0-build.patch b/app-text/hd2u/files/hd2u-1.0.0-build.patch
new file mode 100644
index 000000000000..66b32bbc17c7
--- /dev/null
+++ b/app-text/hd2u/files/hd2u-1.0.0-build.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.in b/Makefile.in
+index 328016c..f8cc6aa 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -36,7 +36,7 @@ LIBS= @LIBS@
+ all: $(TARGET)
+
+ $(TARGET): $(TARGET).c config.h
+- $(CC) $(CFLAGS) -o $@ $(@:%=%.c) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(@:%=%.c) $(LIBS)
+
+ rebuild: cleanall $(TARGET)
+
+@@ -59,9 +59,10 @@ cleanall: clean
+ mrproper: cleanall
+ distclean: cleanall
+
++BUILD_ROOT=$(DESTDIR)
+ install:
+ $(INSTALL) -d -m 755 $(BUILD_ROOT)$(BIN_DIR)
+- $(INSTALL) -m 755 -s $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
++ $(INSTALL) -m 755 $(TARGET) $(BUILD_ROOT)$(BIN_DIR)
+
+ tarball:
+ $(INSTALL) -d -m 755 ./$(PACKAGE_NAME)-$(PACKAGE_VERSION)