summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/Manifest1
-rw-r--r--app-office/planner/metadata.xml5
-rw-r--r--app-office/planner/planner-0.14.6_p20130520.ebuild73
3 files changed, 79 insertions, 0 deletions
diff --git a/app-office/planner/Manifest b/app-office/planner/Manifest
new file mode 100644
index 000000000000..e084edf4fdfd
--- /dev/null
+++ b/app-office/planner/Manifest
@@ -0,0 +1 @@
+DIST planner-0.14.6_p20130520.tar.xz 4200624 SHA256 06b94c7145bbf1f61b6b4ddb847cd2db79f322ee6f89637340ece139eedf8569 SHA512 d658b68c96742340a06a9e96d7910f70fb296cb7a19cc335afdcbec01b36326b1574522155cf19fec012363e1e4d4120c35e1319c699613833be2eb0fa999024 WHIRLPOOL f44941557e2b9af7ab3bebbac59e4d53ac60af7943e5ad03edb249a19ecadc37cfe6530e8295420c84f13b2b2f962a8d9c58bb2345eb4701abfa3dd462f209db
diff --git a/app-office/planner/metadata.xml b/app-office/planner/metadata.xml
new file mode 100644
index 000000000000..20d13ee7e217
--- /dev/null
+++ b/app-office/planner/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-office</herd>
+</pkgmetadata>
diff --git a/app-office/planner/planner-0.14.6_p20130520.ebuild b/app-office/planner/planner-0.14.6_p20130520.ebuild
new file mode 100644
index 000000000000..69891ffd1c88
--- /dev/null
+++ b/app-office/planner/planner-0.14.6_p20130520.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Project manager for Gnome"
+HOMEPAGE="http://live.gnome.org/Planner/"
+SRC_URI="http://dev.gentoo.org/~eva/distfiles/${PN}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE="eds examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.14:2
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4:2.0
+ >=gnome-base/gconf-2.6:2
+ >=dev-libs/libxml2-2.6.27:2
+ >=dev-libs/libxslt-1.1.23
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.6:2[${PYTHON_USEDEP}] )
+ eds? (
+ >=gnome-extra/evolution-data-server-3.6:=
+ >=mail-client/evolution-3.6 )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.5
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-0.14.6"
+
+src_configure() {
+ # FIXME: disable eds backend for now, it fails, upstream bug #654005
+ # We need to set compile-warnings to a different value as it doesn't use
+ # standard macro: https://bugzilla.gnome.org/703067
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_enable python python-plugin) \
+ $(use_enable eds) \
+ --disable-eds-backend \
+ --with-database=no \
+ --disable-update-mimedb \
+ --enable-compile-warnings=yes
+ #$(use_enable eds eds-backend)
+}
+
+src_install() {
+ # error: relink `libstorage-mrproject-1.la' with the above command before installing it
+ # Try to drop workaround on next snapshot or bump
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}