summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ps3pf_utils')
-rw-r--r--app-misc/ps3pf_utils/Manifest3
-rw-r--r--app-misc/ps3pf_utils/metadata.xml5
-rw-r--r--app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild21
-rw-r--r--app-misc/ps3pf_utils/ps3pf_utils-2.2.0.ebuild22
-rw-r--r--app-misc/ps3pf_utils/ps3pf_utils-2.3.ebuild22
5 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/ps3pf_utils/Manifest b/app-misc/ps3pf_utils/Manifest
new file mode 100644
index 000000000000..70d6a975c273
--- /dev/null
+++ b/app-misc/ps3pf_utils/Manifest
@@ -0,0 +1,3 @@
+DIST ps3-utils-2.2.0.tar.bz2 361144 SHA256 b457354fd828229aedfb243fe0df748c2778f295ec1a4297e2cfa47b5b666b8b SHA512 278b4430e307493481ccbe5f1c92968921d5af9b2d09a80a9356ccce984318356183be4983ae5c13bd5e79c2e28c839df0402382d8be5d342a8605236cc060f1 WHIRLPOOL b2be34a1aefacee857450bbee1712f4fd7ae5a1229ab3aeeb93ed5bdad58da912a9a0c5be11657d903e469bf578cfda08fa043fecdaf806a83b15848760bca59
+DIST ps3-utils-2.3.tar.bz2 351066 SHA256 c44a84da3cf37ecc69b36f6079a814e680cf37c74cb7d55f457635adb8209351 SHA512 523e8c28325dc77478cc910a62249bfcd29b35b50e9b01d0d6dec600af302a4a3eff532b313d82fb23c4ff5436955629d8a72f1afb03b76f2b1b9cbd534e8396 WHIRLPOOL ca14e25d139bf4196104075ed8780bbd553e303192710f1cbfa432612fa78f21463a5eb249f1d3963f27876c2a067607331d84b260954870db1599f2ac2d77e9
+DIST ps3pf_utils-2.1.1.tar.bz2 980229 SHA256 9fc907b3b82198ae2ca45699885f1b7f4d28c7d8df1b8ef96ba3cd8476f0cd49 SHA512 5ac971659d946aff3bbaa5090f65018c67bf42309bb855742f1e21d226d619d9f16495396527fe7121d8a5599f5f7496127cb06b011d80b780de19bb73ce668d WHIRLPOOL f19978fcb733d926673fa8849ff4589cf53d91dcc739e1c03db95913c598a0118ca9b3eb6fea7a982fa3bbf31127305f14ffebc2d32f549db48c3d3553a63cd1
diff --git a/app-misc/ps3pf_utils/metadata.xml b/app-misc/ps3pf_utils/metadata.xml
new file mode 100644
index 000000000000..f9a5b22fcbec
--- /dev/null
+++ b/app-misc/ps3pf_utils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc64</herd>
+</pkgmetadata>
diff --git a/app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild b/app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild
new file mode 100644
index 000000000000..e034fb60bb29
--- /dev/null
+++ b/app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="Utilities to set the ps3 specific features"
+HOMEPAGE="http://www.playstation.com/ps3-openplatform/index.html"
+#SRC_URI="http://www.powerdeveloper.org/files/Cell/SourceCD/${P}.tar.bz2
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+# fixme: depend on a version of sys-kernel/linux-headers that supports ps3
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/app-misc/ps3pf_utils/ps3pf_utils-2.2.0.ebuild b/app-misc/ps3pf_utils/ps3pf_utils-2.2.0.ebuild
new file mode 100644
index 000000000000..a4ab67e1d5b6
--- /dev/null
+++ b/app-misc/ps3pf_utils/ps3pf_utils-2.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="Utilities to set the ps3 specific features"
+HOMEPAGE="http://www.playstation.com/ps3-openplatform/index.html"
+SRC_URI="mirror://gentoo/ps3-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-ppc -ppc64"
+IUSE=""
+
+# fixme: depend on a version of sys-kernel/linux-headers that supports ps3
+
+S=${WORKDIR}/ps3-utils-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/app-misc/ps3pf_utils/ps3pf_utils-2.3.ebuild b/app-misc/ps3pf_utils/ps3pf_utils-2.3.ebuild
new file mode 100644
index 000000000000..1e18e38f1b13
--- /dev/null
+++ b/app-misc/ps3pf_utils/ps3pf_utils-2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+DESCRIPTION="Utilities to set the ps3 specific features"
+HOMEPAGE="http://www.playstation.com/ps3-openplatform/index.html"
+SRC_URI="mirror://kernel/linux/kernel/people/geoff/cell/ps3-utils/ps3-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+# fixme: depend on a version of sys-kernel/linux-headers that supports ps3
+
+S=${WORKDIR}/ps3-utils-${PV}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}