summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-qt/files')
-rw-r--r--app-i18n/ibus-qt/files/ibus-qt-1.2.0.20091217-doc.patch21
-rw-r--r--app-i18n/ibus-qt/files/ibus-qt-1.3-doc.patch11
-rw-r--r--app-i18n/ibus-qt/files/ibus-qt-1.3.1-display-unset.patch76
-rw-r--r--app-i18n/ibus-qt/files/ibus-qt-1.3.1-gold.patch15
-rw-r--r--app-i18n/ibus-qt/files/ibus-qt-1.3.1-qvariant.patch29
5 files changed, 152 insertions, 0 deletions
diff --git a/app-i18n/ibus-qt/files/ibus-qt-1.2.0.20091217-doc.patch b/app-i18n/ibus-qt/files/ibus-qt-1.2.0.20091217-doc.patch
new file mode 100644
index 000000000000..a2adbd7b9538
--- /dev/null
+++ b/app-i18n/ibus-qt/files/ibus-qt-1.2.0.20091217-doc.patch
@@ -0,0 +1,21 @@
+--- ibus-qt-1.2.0.20091217-Source.orig/CMakeLists.txt 2009-12-17 14:50:00.000000000 +0900
++++ ibus-qt-1.2.0.20091217-Source/CMakeLists.txt 2010-01-03 09:11:53.000000000 +0900
+@@ -76,7 +76,7 @@
+ # pkg_check_modules(IBUS REQUIRED ibus-1.0>=1.2.0)
+
+ # check doxygen
+-find_package(Doxygen REQUIRED)
++find_package(Doxygen)
+
+ # =====
+ # Define variables
+@@ -100,8 +100,7 @@
+ # install
+ set(MAIN_DOCS
+ AUTHORS
+- README
+- INSTALL)
++ README)
+ install(FILES ${MAIN_DOCS}
+ DESTINATION ${DOCDIR})
+
diff --git a/app-i18n/ibus-qt/files/ibus-qt-1.3-doc.patch b/app-i18n/ibus-qt/files/ibus-qt-1.3-doc.patch
new file mode 100644
index 000000000000..a35e673110ed
--- /dev/null
+++ b/app-i18n/ibus-qt/files/ibus-qt-1.3-doc.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2014-08-04 15:26:19.636569061 +0200
++++ CMakeLists.txt 2014-08-04 15:26:54.637618456 +0200
+@@ -77,7 +77,7 @@
+ pkg_check_modules(IBUS REQUIRED ibus-1.0>=1.3.7)
+
+ # check doxygen
+-find_package(Doxygen REQUIRED)
++find_package(Doxygen)
+
+ # =====
+ # Define variables
diff --git a/app-i18n/ibus-qt/files/ibus-qt-1.3.1-display-unset.patch b/app-i18n/ibus-qt/files/ibus-qt-1.3.1-display-unset.patch
new file mode 100644
index 000000000000..8325779282f4
--- /dev/null
+++ b/app-i18n/ibus-qt/files/ibus-qt-1.3.1-display-unset.patch
@@ -0,0 +1,76 @@
+From d2a4e30fdb92aeaf476dcaaf2b5d6f8275d6af70 Mon Sep 17 00:00:00 2001
+From: Peter Wu <lekensteyn@gmail.com>
+Date: Tue, 4 Sep 2012 19:40:08 +0200
+Subject: [PATCH] Do not crash on missing/invalid DISPLAY envvar.
+
+- Check whether the passed DISPLAY environment variable contains ":".
+
+- Fallback to "-display" parameter passed to QApplication.
+---
+ src/CMakeLists.txt | 2 ++
+ src/qibusbus.cpp | 23 ++++++++++++++++-------
+ 2 files changed, 18 insertions(+), 7 deletions(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 2ad5588..8866ac0 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -92,9 +92,11 @@ set_target_properties(
+ target_link_libraries(
+ ibus-qt
+ debug ${QT_QTCORE_LIBRARY_DEBUG}
++ debug ${QT_QTGUI_LIBRARY_DEBUG}
+ debug ${QT_QTDBUS_LIBRARY_DEBUG}
+ debug ${QT_QTXML_LIBRARY_DEBUG}
+ optimized ${QT_QTCORE_LIBRARY_RELEASE}
++ optimized ${QT_QTGUI_LIBRARY_RELEASE}
+ optimized ${QT_QTDBUS_LIBRARY_RELEASE}
+ optimized ${QT_QTXML_LIBRARY_RELEASE}
+ ${DBUS_LIBRARIES}
+diff --git a/src/qibusbus.cpp b/src/qibusbus.cpp
+index 6a45d65..ed8248a 100644
+--- a/src/qibusbus.cpp
++++ b/src/qibusbus.cpp
+@@ -12,7 +12,8 @@
+ #include "qibusbus.h"
+ #include "qibusibusproxy.h"
+ #include "qibusdbusproxy.h"
+-
++#include <X11/Xlib.h>
++#include <QX11Info>
+
+ namespace IBus {
+ /**
+@@ -121,15 +122,23 @@
+ Bus::getSocketPath (void)
+ {
+ QString display = getenv ("DISPLAY");
+- QStringList strs = display.split(":");
+ QString hostname = "unix";
+ QString display_number = "0";
++ /* fallback when -display is passed to QApplication with no DISPLAY env */
++ if (display == NULL) {
++ Display * dpy = QX11Info::display();
++ if (dpy)
++ display = XDisplayString(dpy);
++ }
++ if (display != NULL && display.contains(':')) {
++ QStringList strs = display.split(":");
+
+- if (!strs[0].isEmpty())
+- hostname = strs[0];
+- strs = strs[1].split(".");
+- if (!strs[0].isEmpty())
+- display_number = strs[0];
++ if (!strs[0].isEmpty())
++ hostname = strs[0];
++ strs = strs[1].split(".");
++ if (!strs[0].isEmpty())
++ display_number = strs[0];
++ }
+
+ QString path =
+ QDir::homePath() +
+--
+1.7.10
+
diff --git a/app-i18n/ibus-qt/files/ibus-qt-1.3.1-gold.patch b/app-i18n/ibus-qt/files/ibus-qt-1.3.1-gold.patch
new file mode 100644
index 000000000000..3d1080269110
--- /dev/null
+++ b/app-i18n/ibus-qt/files/ibus-qt-1.3.1-gold.patch
@@ -0,0 +1,15 @@
+ src/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 8866ac0..f419141 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -100,6 +100,7 @@ target_link_libraries(
+ optimized ${QT_QTDBUS_LIBRARY_RELEASE}
+ optimized ${QT_QTXML_LIBRARY_RELEASE}
+ ${DBUS_LIBRARIES}
++ ${X11_LIBRARIES}
+ )
+
+ install(TARGETS ibus-qt
diff --git a/app-i18n/ibus-qt/files/ibus-qt-1.3.1-qvariant.patch b/app-i18n/ibus-qt/files/ibus-qt-1.3.1-qvariant.patch
new file mode 100644
index 000000000000..23981b35ded5
--- /dev/null
+++ b/app-i18n/ibus-qt/files/ibus-qt-1.3.1-qvariant.patch
@@ -0,0 +1,29 @@
+From 40e119bd5577fc383990ad02b175ec64292f764b Mon Sep 17 00:00:00 2001
+From: Jekyll Wu <adaptee@gmail.com>
+Date: Tue, 16 Oct 2012 11:24:06 +0900
+Subject: [PATCH] Fix a non-const lvalue build error with clang-3.1
+
+BUG=http://code.google.com/p/ibus/issues/detail?id=1506
+
+Review URL: https://codereview.appspot.com/6697048
+Patch from Jekyll Wu <adaptee@gmail.com>.
+---
+ src/qibusserializable.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qibusserializable.h b/src/qibusserializable.h
+index 594d973..92a32ed 100644
+--- a/src/qibusserializable.h
++++ b/src/qibusserializable.h
+@@ -91,7 +91,7 @@ class Serializable : public Object
+
+ template<typename T>
+ QVariant &
+-qVariantFromSerializable (const Pointer<T> &p, QVariant & variant = QVariant ())
++qVariantFromSerializable (const Pointer<T> &p, QVariant & variant)
+ {
+ QDBusArgument argument;
+
+--
+1.8.1.5
+