summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/windows/windows-2.53.ebuild')
-rw-r--r--app-emacs/windows/windows-2.53.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/windows/windows-2.53.ebuild b/app-emacs/windows/windows-2.53.ebuild
new file mode 100644
index 000000000000..1d66f961b5b5
--- /dev/null
+++ b/app-emacs/windows/windows-2.53.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Window manager for GNU Emacs"
+HOMEPAGE="https://www.gentei.org/~yuuji/software/"
+# taken from https://www.gentei.org/~yuuji/software/euc/${PN}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/revive"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}