summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/plantuml/plantuml-0.8046.ebuild (renamed from media-gfx/plantuml/plantuml-8046.ebuild)7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-gfx/plantuml/plantuml-8046.ebuild b/media-gfx/plantuml/plantuml-0.8046.ebuild
index 57239acc9c8a..0db55ffddc12 100644
--- a/media-gfx/plantuml/plantuml-8046.ebuild
+++ b/media-gfx/plantuml/plantuml-0.8046.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
JAVA_PKG_IUSE="source"
inherit java-pkg-2 java-ant-2
+MY_VER=$(ver_cut 2)
DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
HOMEPAGE="http://plantuml.com"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_VER}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~x86"
@@ -19,6 +20,8 @@ RDEPEND=">=virtual/jre-1.7
dev-java/ant-core:0
>=media-gfx/graphviz-2.26.3"
+S="${WORKDIR}/${PN}-${MY_VER}"
+
EANT_BUILD_TARGET="dist"
EANT_GENTOO_CLASSPATH="ant-core"
JAVA_ANT_REWRITE_CLASSPATH="true"