summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/wtfis-0.9.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
index 2f306e359f37..ca6a08a90466 100644
--- a/net-analyzer/wtfis/Manifest
+++ b/net-analyzer/wtfis/Manifest
@@ -1,2 +1,3 @@
DIST wtfis-0.7.1.gh.tar.gz 548395 BLAKE2B fbcc19358a0a357fdc9f4b5f27d4bda60e20a118c3c3b7cdfd90fad956d2ef0375efe4f0c8a3a94bfa8a6657d5bb710eaacb403b8c3d446921b963e3e8909442 SHA512 9a77c17e1e922e6d17aba9c6cc7364c8b65bc401cbca311280a4eef958056238aef87c2a8891c1bce5848083d1a7e5e00b0b63ead5ffefdea80ae7baee40c845
DIST wtfis-0.8.0.gh.tar.gz 576810 BLAKE2B ac4573893aacc2533fe9ed3248613d3bf5ffb390a2dcbf01fd0590093a7bf753ee8da6e67b60142111726d55928a7913bb3f7ae1a22474876dec1cb3d81d3a3c SHA512 b709948d0ccd75472d9ccc0bfc4cec943700e57eccc42cc486075b8b89516fff054b6df92d6b23999987bab97b80db755de575cba4b56e2bd01a6bf24f058798
+DIST wtfis-0.9.1.gh.tar.gz 590558 BLAKE2B e4d1b70bd979b1cdf5c09e9adcf2e9484eb15a8986dc4c1f88d29af830f18a6974a6f5ec5cbb808c039df85aad708dec822ccdd8c765507c1a62084d6173e1c0 SHA512 72b6725c62d7345440021e57144c637e0c5503cfd870a8626707508428dc0ba24ae183b11836c726a58de6f2103e57cb7a3be4d132f7c8b758f88463d195dcc2
diff --git a/net-analyzer/wtfis/wtfis-0.9.1.ebuild b/net-analyzer/wtfis/wtfis-0.9.1.ebuild
new file mode 100644
index 000000000000..5982358071db
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~loong ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest