summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/http2/Manifest1
-rw-r--r--dev-haskell/http2/http2-1.3.1.ebuild47
-rw-r--r--dev-haskell/http2/metadata.xml9
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/http2/Manifest b/dev-haskell/http2/Manifest
new file mode 100644
index 000000000000..3d1cecf8a9da
--- /dev/null
+++ b/dev-haskell/http2/Manifest
@@ -0,0 +1 @@
+DIST http2-1.3.1.tar.gz 39493 SHA256 547aa0826373711e4ec8d271f767cd8db74ac3cb822cdf58d305c18babd22f96 SHA512 7d47cb35ce55743ecdc19ea52a1e230c8c3d608348f658ed7b3eb4f86a93ad4aa16eb23e4294dc1752bd99da8027e61a0b575ee9b89fe182d6582f6b5b402cee WHIRLPOOL d0852b262b44bb9b9e306f8e2d605dc8646a3568a52553cdb50d5bef792d929967c48f79aa429906098ac78017ec6a202afa41cb533bafd6d5bb7d810a4347c7
diff --git a/dev-haskell/http2/http2-1.3.1.ebuild b/dev-haskell/http2/http2-1.3.1.ebuild
new file mode 100644
index 000000000000..49e26aa43186
--- /dev/null
+++ b/dev-haskell/http2/http2-1.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -devel
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP/2.0 library including frames and HPACK"
+HOMEPAGE="http://hackage.haskell.org/package/http2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # missing files
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/aeson-pretty:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ dev-haskell/hex:=[profile?]
+ dev-haskell/psqueues:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.9.3
+ dev-haskell/glob
+ >=dev-haskell/hspec-1.3
+ dev-haskell/mwc-random )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-devel
+}
diff --git a/dev-haskell/http2/metadata.xml b/dev-haskell/http2/metadata.xml
new file mode 100644
index 000000000000..a575d8870f71
--- /dev/null
+++ b/dev-haskell/http2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ HTTP/2.0 library including frames and HPACK.
+ Currently HTTP/2 16 framing and HPACK 10 is supported.
+ </longdescription>
+</pkgmetadata>