summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/angst/angst-0.4b-r3.ebuild45
-rw-r--r--net-analyzer/angst/files/0.4b-flags.patch20
2 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/angst/angst-0.4b-r3.ebuild b/net-analyzer/angst/angst-0.4b-r3.ebuild
new file mode 100644
index 000000000000..8054d460f586
--- /dev/null
+++ b/net-analyzer/angst/angst-0.4b-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="an active sniffer that provides methods for aggressive sniffing on switched LANs"
+HOMEPAGE="http://angst.sourceforge.net/"
+SRC_URI="http://angst.sourceforge.net/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PV}-flags.patch
+ "${FILESDIR}"/${PV}-libnet-1.0.patch
+)
+
+src_configure() {
+ append-cflags -fcommon
+ use debug && append-cppflags -DDEBUG
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ -f Makefile.linux
+}
+
+src_install() {
+ dosbin angst
+ doman angst.8
+ dodoc README TODO ChangeLog
+}
diff --git a/net-analyzer/angst/files/0.4b-flags.patch b/net-analyzer/angst/files/0.4b-flags.patch
new file mode 100644
index 000000000000..1021faa5b539
--- /dev/null
+++ b/net-analyzer/angst/files/0.4b-flags.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -5,7 +5,7 @@
+ #
+ # $Id: Makefile.linux,v 1.6 2001/02/08 13:44:12 argp Exp $
+
+-CC = gcc
++CC ?= gcc
+ INSTALL_DIR = /usr/bin/install -c -o root -g bin
+ INSTALL_SBIN = /usr/bin/install -c -s -o root -g bin -m 555
+ INSTALL_MAN = /usr/bin/install -c -o root -g bin -m 444
+@@ -21,7 +21,7 @@
+ all: angst
+
+ angst: $(OBJS)
+- $(CC) $(CFLAGS) -o angst $(DEFINE) $(OBJS) $(INCLUDE) $(LIBS)
++ $(CC) $(CFLAGS) -o angst $(DEFINE) $(LDFLAGS) $(OBJS) $(INCLUDE) $(LIBS)
+
+ clean:
+ rm -f angst *.o missing/*.o *.core core