summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/tpm2-pkcs11/Manifest1
-rw-r--r--app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.3.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/tpm2-pkcs11/Manifest b/app-crypt/tpm2-pkcs11/Manifest
index 59b50a7143d1..82871d4a6970 100644
--- a/app-crypt/tpm2-pkcs11/Manifest
+++ b/app-crypt/tpm2-pkcs11/Manifest
@@ -1 +1,2 @@
DIST tpm2-pkcs11-1.2.0.tar.gz 1253641 BLAKE2B e4f673f6cb3b697426f4ba01324939214e74a74edee24a184de860d54d7b8c3f437716245552e06711c258eed88b7556771f2614f3a4dacdec5a986a5c9697d4 SHA512 e7de454b38388c4562fc92282855c1ed9a04c7968c358d6918137257fb5a1ca785c2297e8a34464ea04eed86acd9fc5b59c837027da9d3f195ec86ff0563feeb
+DIST tpm2-pkcs11-1.3.0.tar.gz 1257620 BLAKE2B 503a84a42f1698d1ae85d70473365bf2a58d4f6b8b4ae12629bbb9178de7f33655780b43d4e32f8489006b8e52dcb5cb8ba2a16844319ea5423ce11e9bb84f1d SHA512 27d48dd78534008ef7254f03673101a27740561bc0ad15dd3972d829d2e4677ed2e30d6cc95c6564ad225eb8652c9876cd9cbfab48a749b6d1576fae1b7a6ce2
diff --git a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.3.0.ebuild b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.3.0.ebuild
new file mode 100644
index 000000000000..808767d4003e
--- /dev/null
+++ b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
+HOMEPAGE="https://tpm2-software.github.io/"
+SRC_URI="https://github.com/tpm2-software/tpm2-pkcs11/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Test requires the IBM TPM simulator that's not in portage
+RESTRICT="test"
+
+RDEPEND="app-crypt/p11-kit
+ app-crypt/tpm2-abrmd
+ app-crypt/tpm2-tss
+ dev-db/sqlite:3
+ dev-libs/openssl
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ default
+ cd "${S}/tools" || die
+ BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_compile
+}
+
+src_install() {
+ default
+ cd "${S}/tools" || die
+ BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_install
+ dobin "${S}/tools/tpm2_ptool"
+}