summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aiohttp-socks/Manifest1
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.8.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index 982493d89282..c9ef5ca4fb00 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -2,3 +2,4 @@ DIST aiohttp-socks-0.8.0.gh.tar.gz 13190 BLAKE2B 049655c526b5d7b64af79ef5f885d0f
DIST aiohttp-socks-0.8.1.gh.tar.gz 13336 BLAKE2B 39ad70fe9f1eb8d4f743c4d65dafb82c0878808b0861f899b12ba437ef80a9e4f077485c37fb8267588ac307446ea0c2d26c02de05cd3f44a76896610cc85cc4 SHA512 f8d30d6c6aa32968bbcf075d016ecc542835f6bdc2f0bbe1ffa06e580ab851a4f5abdac8d008e639d0cff49829a299afa42a80e159d7fece67439e5384817d85
DIST aiohttp-socks-0.8.2.gh.tar.gz 13563 BLAKE2B 4e16abf9ed3f31fbbb8604587f2249a5387dbb1acc8a29d1999b52e84a5be3a0795073867a18c97c5c397f0742d75d4246a71484066bb8970a3d2356b482c8da SHA512 7fd7863bb7aa315a678516f02c2b4c2ba9dfb9e38ac7f1dd7ea78f474f005ee82334262c1bc31ba289554aa1a9e657a2f16dcf1950f16a2b959563b4016c3e88
DIST aiohttp-socks-0.8.3.gh.tar.gz 13291 BLAKE2B e7e757d966bff9943bb162e0aa4dce597afeb044da84db80b39a80b0431fa442850a4b3c09aad06fb8c78f90d508be5190dab1ef1d543e42a4a161ab056e0935 SHA512 53e164be4f8459c7a4df015f60a8d70971473a0ba7a39b32cdbd0499e7316d0d211ddead7e3c065516b1082804fbbedca8e75bb7b59f1abd893b395840b147dc
+DIST aiohttp-socks-0.8.4.gh.tar.gz 13568 BLAKE2B a99513b4dd7ca75aca36979c0ace84adcabdc2fb1104d38ae49d07944fa1fb17a2a8da24fa395a33dabc00bc444710d23e911db427c895ec144ac1600d3d5983 SHA512 09a0ca9267ad822546bd47066b2f1b5f15364913da609fa5a2ebd0b0a8fd2f74e7413ab7e2f0970a777c5b853cc2fcae83e7af4eaa7cb4508d7644479ba8afd1
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.8.4.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.8.4.ebuild
new file mode 100644
index 000000000000..4c70e0231116
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.8.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="
+ https://pypi.org/project/aiohttp-socks/
+ https://github.com/romis2012/aiohttp-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.4.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/tiny-proxy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest