summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycparser/pycparser-2.19-r1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.19-r1.ebuild b/dev-python/pycparser/pycparser-2.19-r1.ebuild
index 3b8d5a5df7df..18ac75c43138 100644
--- a/dev-python/pycparser/pycparser-2.19-r1.ebuild
+++ b/dev-python/pycparser/pycparser-2.19-r1.ebuild
@@ -32,6 +32,17 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_compile() {
+ distutils-r1_python_compile
+
+ # note: tables built by py3.5+ are incompatible with older versions
+ # because of 100 group limit of 're' module -- just generate them
+ # separately optimized for each target instead
+ pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
+ "${PYTHON}" _build_tables.py || die
+ popd > /dev/null || die
+}
+
python_test() {
# change workdir to avoid '.' import
nosetests -v -w tests || die