summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch15
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r3.ebuild (renamed from dev-lang/ghc/ghc-9.0.2-r2.ebuild)5
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch b/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch
new file mode 100644
index 000000000000..ee4132bb2ee8
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-9.0.2-llvm-14.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/876187
+
+Bump max LLVM to 14. Validated on arm64.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -681,7 +681,7 @@ AC_SUBST(InstallNameToolCmd)
+ # versions of LLVM simultaneously, but that stopped working around
+ # 3.5/3.6 release of LLVM.
+ LlvmMinVersion=9 # inclusive
+-LlvmMaxVersion=14 # not inclusive
++LlvmMaxVersion=15 # not inclusive
+ AC_SUBST([LlvmMinVersion])
+ AC_SUBST([LlvmMaxVersion])
+ sUPPORTED_LLVM_VERSION_MIN=$(echo \($LlvmMinVersion\) | sed 's/\./,/')
diff --git a/dev-lang/ghc/ghc-9.0.2-r2.ebuild b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
index 224ca5ec3652..b7d4466a00c3 100644
--- a/dev-lang/ghc/ghc-9.0.2-r2.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
@@ -85,7 +85,7 @@ IUSE="big-endian +doc elfutils ghcbootstrap ghcmakebinary +gmp llvm numa profile
IUSE+=" binary"
RESTRICT="!test? ( test )"
-LLVM_MAX_SLOT="13"
+LLVM_MAX_SLOT="14"
RDEPEND="
>=dev-lang/perl-5.6.1
dev-libs/gmp:0=
@@ -96,7 +96,7 @@ RDEPEND="
llvm? (
<sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):=
|| (
- sys-devel/llvm:13
+ sys-devel/llvm:14
)
)
"
@@ -540,6 +540,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-8.10.1-allow-cross-bootstrap.patch
eapply "${FILESDIR}"/${PN}-9.0.2-disable-unboxed-arrays.patch
eapply "${FILESDIR}"/${PN}-9.0.2-llvm-13.patch
+ eapply "${FILESDIR}"/${PN}-9.0.2-llvm-14.patch
eapply "${FILESDIR}"/latomic-subword
eapply "${WORKDIR}"/${P}-riscv64-llvm.patch
eapply "${FILESDIR}"/${PN}-9.0.2-fptools.patch # clang-16 workaround