summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.7.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index a5d6e7411d14..43ea8f4e7f87 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,5 +1,4 @@
DIST nghttp2-1.6.0.tar.gz 1983953 SHA256 c88012e87b80c055ddd2412efd7e96b9e8cfe0652c4b21083f2cb89b2f0d3a26 SHA512 32d5227a5ff037d50d93d43b1fdb0be51d9cca1e09dcc85320b8e09f82fdc658397ca58ca400595f138ca7b77f389d945e3562ab4074afd05e1c74eca4de2744 WHIRLPOOL 31102e596a9e93ca993cd9b8b04da6f51acb247803de16958501bdb6fe06e5bbc951430d2c2be1bd7fd1d9216d087d711de83bad6bb93eb70f4e4b8b0f864efb
-DIST nghttp2-1.7.0.tar.gz 2001726 SHA256 f0be9560baa30fc56bcce0151d88126d71b91815bb47076a8dd9ad2b9023ff49 SHA512 556a81ef9bad8a75a23b13532e6066af4412d79fa8dbde508ea893780bc9b19e0525674dc1cfb04b25cc48d62ae704737d6c4b1aa2b442a2be514b72490f6c1b WHIRLPOOL 138bb50c85ef7838be919989c032157ecedbfe1d5bf28633d5ee0c3d6f18dc7fa7525e185d476d146788466b58db0a2104054a1a28cb5152a8c4e9652fcb22ba
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
DIST nghttp2-1.8.0.tar.gz 2021815 SHA256 3ac8cdf47c744cb387e6c867fe8c9a449254e9fab7fdf96782f9eaf7f635320a SHA512 447ee232abb9ea4105044567baabedc471089af7dfe72219f7c830898d3cd9bc63351d187129e43331cc775702f8dbe2afd21a2c88dc5191b858539dcb7c61d2 WHIRLPOOL b3ec7eae828c240dcd2c972d8148ceb6f2476fe8b6b8636c38b68b236e91915f07851a19a1e9daae27c636eb68898b8675e33b9e13d75c51ef99f56d992908dd
DIST nghttp2-1.9.1.tar.gz 2044300 SHA256 6ffa024333265797f3b6161602c646ccadb09a0a5d889609e2dc13697ba615f1 SHA512 e91b8a03e44c9573c3dc65209b16336a9a314c051be04c750c53be15675b2173b568799d3a8c6a4c74ee25733d327ceeaa68e84d03b8f32f68bad487ce6f4717 WHIRLPOOL 85f60ccf76e2ae8ce047e112da46f949734f8ddb7f99c48d0900015ffb0e1f649d561d8365ff10af76e818b96cf018169b8b1fc7b9c0abb45d7384945e396966
diff --git a/net-libs/nghttp2/nghttp2-1.7.0.ebuild b/net-libs/nghttp2/nghttp2-1.7.0.ebuild
deleted file mode 100644
index 776f0f6311a0..000000000000
--- a/net-libs/nghttp2/nghttp2-1.7.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# TODO: Add python support.
-
-EAPI="5"
-
-inherit multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
- inherit git-2
-else
- SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-DESCRIPTION="HTTP/2 C Library"
-HOMEPAGE="https://nghttp2.org/"
-
-LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
-IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
-
-RDEPEND="
- cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
- hpack-tools? ( >=dev-libs/jansson-2.5 )
- jemalloc? ( dev-libs/jemalloc )
- utils? (
- >=dev-libs/libev-4.15
- !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist] )
- libressl? ( dev-libs/libressl )
- >=sys-libs/zlib-1.2.3
- )
- xml? ( >=dev-libs/libxml2-2.7.7:2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --disable-examples \
- --disable-failmalloc \
- --disable-werror \
- --without-cython \
- --disable-python-bindings \
- --without-spdylay \
- $(use_enable cxx asio-lib) \
- $(use_enable debug) \
- $(multilib_native_use_enable hpack-tools) \
- $(use_enable static-libs static) \
- $(use_enable threads) \
- $(multilib_native_use_enable utils app) \
- $(multilib_native_use_with jemalloc) \
- $(multilib_native_use_with xml libxml2)
-}
-
-multilib_src_install_all() {
- use static-libs || find "${ED}" -name '*.la' -delete
-}