summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 21:22:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 21:22:32 +0200
commit790091f2bd8cbd8c1568a8da7133404d526725b5 (patch)
treee85877079bcd0b72ce8607b6fbced6b5a1c3e355 /xfce-extra/xfce4-time-out-plugin
parentapp-emulation/virtualbox-modules: fix for empty KV_DIR (diff)
downloadgentoo-790091f2bd8cbd8c1568a8da7133404d526725b5.tar.gz
gentoo-790091f2bd8cbd8c1568a8da7133404d526725b5.tar.bz2
gentoo-790091f2bd8cbd8c1568a8da7133404d526725b5.zip
xfce-extra/xfce4-time-out-plugin: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-time-out-plugin')
-rw-r--r--xfce-extra/xfce4-time-out-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/Manifest b/xfce-extra/xfce4-time-out-plugin/Manifest
index 6d2e04a15e8a..19c627c89e66 100644
--- a/xfce-extra/xfce4-time-out-plugin/Manifest
+++ b/xfce-extra/xfce4-time-out-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-time-out-plugin-1.1.2.tar.bz2 409221 BLAKE2B 75a6f646badb936a803d8e6a8c9c25c85fa76f96fa82bae742724d3b52a68c49f81f58600a91de6ceb0f85220aa2d6b3a3ae2525a38e4f8a5fd78d4fbc6f0dfc SHA512 08e50db9daafd9a2ba60e9d5767cddba83df34d8a261df71b7bb9ae632576f4dfd6252c2a83ec8f9a037284b0adc65751ba36d54ea9d14b85906fdc85d5b86ff
+DIST xfce4-time-out-plugin-1.1.3.tar.bz2 407981 BLAKE2B 4dd2e7ecd4bad79d0e16d94ee5f5f616477a5f0cd0a6eb29612bd2bc35e92d57aa05781c28b1257f50b0f3eb53bef20a3a6d6658b2657a356aa452a097e6b7f1 SHA512 1abb5b8efa985b08968c49bb01a6efd49bc43f16f4b80f892086643444979dab3b7819d7f7e51e4c898c92387c213684b0c28765624c1f04303c0674c5b91930
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild
new file mode 100644
index 000000000000..7403e17ef3ad
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-time-out-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-time-out-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}