summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-17 22:25:40 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-06 15:54:09 +0200
commit86dcb28749babcf3d9bef76312dfb12dd713129e (patch)
treea7c8e7b4fbd2eb3a0686fad6a4b029c97041646d /xfce-extra/xfce4-statusnotifier-plugin
parentdev-libs/libdbusmenu: Bump to 16.04.0, fix tests, EAPI=6 (diff)
downloadgentoo-86dcb28749babcf3d9bef76312dfb12dd713129e.tar.gz
gentoo-86dcb28749babcf3d9bef76312dfb12dd713129e.tar.bz2
gentoo-86dcb28749babcf3d9bef76312dfb12dd713129e.zip
xfce-extra/xfce4-statusnotifier-plugin: New package
Diffstat (limited to 'xfce-extra/xfce4-statusnotifier-plugin')
-rw-r--r--xfce-extra/xfce4-statusnotifier-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-statusnotifier-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-statusnotifier-plugin/Manifest b/xfce-extra/xfce4-statusnotifier-plugin/Manifest
new file mode 100644
index 000000000000..6a7f65fc8673
--- /dev/null
+++ b/xfce-extra/xfce4-statusnotifier-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-statusnotifier-plugin-0.1.0.tar.bz2 361454 SHA256 22ad14101df914e79d4dbd8e5d96382b1d3f52e326d2acd7760bfbf9795ea6d5 SHA512 23c84700bd538115237c525f416ea545b10b6ea4e674c3e136ccf8f7a48370b978e99dac6c69ed694c3dd495027825bc9e74504e0222c6a3923f52e4b9d4f097 WHIRLPOOL fdb205e8a38692ac4ee37e54342704bcdff7c8d01a918553ecf1d1ab67ff37d1cee04e72b415b4747d3d29aa284babfe558b0f947bf8cef87aac92e9aeb354fa
diff --git a/xfce-extra/xfce4-statusnotifier-plugin/metadata.xml b/xfce-extra/xfce4-statusnotifier-plugin/metadata.xml
new file mode 100644
index 000000000000..359901b31db4
--- /dev/null
+++ b/xfce-extra/xfce4-statusnotifier-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild b/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild
new file mode 100644
index 000000000000..01a0cd1f11aa
--- /dev/null
+++ b/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A panel area for fd.o Status Notifiers (systray replacement)"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-statusnotifier-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.24:=
+ >=dev-libs/libdbusmenu-16.04.0:=[gtk3]
+ >=x11-libs/gtk+-3.18:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}