summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-01 17:27:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-01 17:27:06 +0100
commit1e4d0f9287bbe65bf99de2dd116e747cdd4112f9 (patch)
tree55f454b0838959f806e9b78b0f113da5895bf818 /xfce-base/xfwm4
parentxfce-base/xfconf: Bump to 4.19.5 (diff)
downloadgentoo-1e4d0f9287bbe65bf99de2dd116e747cdd4112f9.tar.gz
gentoo-1e4d0f9287bbe65bf99de2dd116e747cdd4112f9.tar.bz2
gentoo-1e4d0f9287bbe65bf99de2dd116e747cdd4112f9.zip
xfce-base/xfwm4: Bump to 4.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfwm4')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.19.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index fd3625ba8275..39f1b7882c34 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,2 +1,3 @@
DIST xfwm4-4.18.0.tar.bz2 1220901 BLAKE2B 3a3db6368063b94fa46407fbf2173021a91efff04ed3d11c757d3e785de5e70289ae03e138e95979b3801a781c05d5f84b86b29727171796e1b80f874865bb36 SHA512 1003bb1ca5254221a5d56ffcb51c12cdef1b17b9d252622c6b18f3d3fbcf9d6e0e66b5f61e0f6eae6601ea3e50a70be98320e60d6738b04e44879e6f4e6da34d
DIST xfwm4-4.19.0.tar.bz2 1483341 BLAKE2B e04c2259787449ea6070dc1c9375ec8173fb5d7448f350ab74d0c45f616ca141c7abc71c88ac00935ced09b4c70c3a5fe88fbae097966ca9d2fd35d79cab2326 SHA512 6213a8b1c161a81df0d4f1f63a3d004c0d923e6ff9855d37a22b831f32234b677612e15a2abd783e3fcdd47dfe3df9ed0231216e48a475a97b421c1d1f73fcdd
+DIST xfwm4-4.19.1.tar.bz2 1487082 BLAKE2B 2d4361c85479481abf7d6472605adbd56042d9b100b039168b7c6c7f731da4237185fe936b9db4c7d12ecd8d8172dbb95dbbcb249c29c30a01bd884e4edc8b81 SHA512 6f797979368ed60ff5625a782adc0518fea934c0c4a638b5d5c5e402d8e6ff491b94b93a34824555cae009ae4ecc8140e8c16d265ba6a53ff3f6995b27fa1d25
diff --git a/xfce-base/xfwm4/xfwm4-4.19.1.ebuild b/xfce-base/xfwm4/xfwm4-4.19.1.ebuild
new file mode 100644
index 000000000000..355d9fe2ae44
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.19.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfwm4/start
+ https://gitlab.xfce.org/xfce/xfwm4
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ >=x11-libs/gtk+-3.24.0:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )
+ xpresent? ( x11-libs/libXpresent )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-libs/glib
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ $(use_enable xcomposite compositor)
+ $(use_enable xpresent)
+ --enable-randr
+ --enable-render
+ --enable-xi2
+ --enable-xsync
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}