summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-base/libxfce4ui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/Manifest2
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild45
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.12.1-r2.ebuild46
-rw-r--r--xfce-base/libxfce4ui/metadata.xml12
4 files changed, 105 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
new file mode 100644
index 000000000000..ec24790717f2
--- /dev/null
+++ b/xfce-base/libxfce4ui/Manifest
@@ -0,0 +1,2 @@
+DIST libxfce4ui-4.10.0.tar.bz2 545486 SHA256 a2b9fa288ccb5f16fa13264e507ba3f7b8da0176da259a11239f21538c0ea3e2 SHA512 18de63f3198480730460d93bbe10c17bb64cd115cfc3878be3e1c800e209f5bf1a7441b4661e7c09fc6109b76791c952a7792eac0c2b846827a89e3ddfb2292e WHIRLPOOL 80e2b724805b3bfd120c4e8f6e9fff1ae9a1829b4033e7370806ec4ad95ed79410d8c67b0d57b0095c1bac3ed4d0843fdeddcb86f574e83873392b07b52834a2
+DIST libxfce4ui-4.12.1.tar.bz2 665624 SHA256 3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43 SHA512 9d132a81bc3385b6582c2d97ed7a1fc0ea289d9098cc4c3a7fb523329eb6afb18716bcf98a5832c4484794eb7a2be4242fa2e71083cd5e55cb19e3b8003458a8 WHIRLPOOL bfc23f795755af6dc7a0ea947dfc931c3dc8eaa64d73303361d0be8cad77d5a9206d349551995de8a291281270564ed54f947f4c56285f7bc8ae91dfbfdd538d
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild
new file mode 100644
index 000000000000..516b066f7f80
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r2.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r2.ebuild
new file mode 100644
index 000000000000..7d814884bbe6
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug +gtk3 startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ >=x11-libs/gtk+-2.24:2=
+ x11-libs/libX11:=
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ gtk3? ( >=x11-libs/gtk+-3.2:3= )
+ startup-notification? ( x11-libs/startup-notification:= )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable gtk3)
+ $(xfconf_use_debug)
+ # requires deprecated glade:3 (gladeui-1.0), bug #551296
+ --disable-gladeui
+ --with-vendor-info=Gentoo
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}
diff --git a/xfce-base/libxfce4ui/metadata.xml b/xfce-base/libxfce4ui/metadata.xml
new file mode 100644
index 000000000000..d2638716d72c
--- /dev/null
+++ b/xfce-base/libxfce4ui/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name='glade'>Build support for Glade 3's GtkBuilder implementation</flag>
+ <flag name='gtk3'>Enable gtk3 support</flag>
+ </use>
+</pkgmetadata>