summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-19 19:28:44 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-19 20:04:39 +0200
commitc0c44c877a8593126705fdda234d2f0db8303640 (patch)
tree1e39f042831a47d2519e85268e6227635041691c /x11-themes
parentdev-ml/opam-format: drop 2.0.9, 2.0.10 (diff)
downloadgentoo-c0c44c877a8593126705fdda234d2f0db8303640.tar.gz
gentoo-c0c44c877a8593126705fdda234d2f0db8303640.tar.bz2
gentoo-c0c44c877a8593126705fdda234d2f0db8303640.zip
x11-themes/chameleon-xcursors: Use updated location for cursor themes
Closes: https://bugs.gentoo.org/934163 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r3.ebuild b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r3.ebuild
new file mode 100644
index 000000000000..252e0e0d0622
--- /dev/null
+++ b/x11-themes/chameleon-xcursors/chameleon-xcursors-0.5-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+COLOURS=( "Anthracite" "DarkSkyBlue" "SkyBlue" "Pearl" "White" )
+MY_PN="Chameleon"
+
+DESCRIPTION="Style neutral scalable cursor theme"
+HOMEPAGE="https://store.kde.org/p/999948/"
+for COLOUR in "${COLOURS[@]}"; do
+ SRC_URI="${SRC_URI} mirror://gentoo/${MY_PN}-${COLOUR}-${PV}.tar.bz2"
+done
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+src_install() {
+ dodir /usr/share/icons/
+
+ for COLOUR in "${COLOURS[@]}"; do
+ for SIZE in Large Regular Small; do
+ local name="${MY_PN}-${COLOUR}-${SIZE}"
+ rm "${WORKDIR}"/${name}-${PV}/{COPYRIGHT,LICENSE} || die
+ insinto /usr/share/icons/
+ doins -r "${WORKDIR}"/${name}-${PV}
+ done
+ done
+}