summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 12:53:22 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 12:53:22 +0100
commit0d50b34fe6474b1b987b8df839cd9f97fde858d0 (patch)
treef9c98d35b0abb5218c007345e6c7e907c8b1617a /x11-themes
parentx11-themes/nimbus: Port to EAPI 7 (diff)
downloadgentoo-0d50b34fe6474b1b987b8df839cd9f97fde858d0.tar.gz
gentoo-0d50b34fe6474b1b987b8df839cd9f97fde858d0.tar.bz2
gentoo-0d50b34fe6474b1b987b8df839cd9f97fde858d0.zip
x11-themes/nuvox: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/nuvox/files/nuvox-07.1-fix-buildset.patch23
-rw-r--r--x11-themes/nuvox/nuvox-07.1-r1.ebuild21
2 files changed, 31 insertions, 13 deletions
diff --git a/x11-themes/nuvox/files/nuvox-07.1-fix-buildset.patch b/x11-themes/nuvox/files/nuvox-07.1-fix-buildset.patch
new file mode 100644
index 000000000000..fba871878c70
--- /dev/null
+++ b/x11-themes/nuvox/files/nuvox-07.1-fix-buildset.patch
@@ -0,0 +1,23 @@
+--- a/buildset
++++ b/buildset
+@@ -157,7 +157,6 @@
+
+
+ # Move/Remove the created directories so the user can rebuild if needed.
+-rm -fr 32x32/apps 32x32/devices 32x32/mimetypes 32x32/filesystems
+ for size in $SIZES
+ do
+ if [ "$size" != "32x32" ]; then # Already did the 32x32 size above
+@@ -169,12 +168,10 @@
+ echo -ne "Tarring and compressing.\n"
+ if test -f $COMPRESSOR
+ then
+- tar cf $PACKAGENAME.tar $PACKAGENAME && $COMPRESSOR $PACKAGENAME.tar
+ echo -ne "\nThe $PACKAGENAME icon set has been built. Use kcontrol to install the icon set.\n"
+ echo && ls -sh $PACKAGENAME.tar* && echo
+ fi
+ echo -ne "Removing all temporary directories...\n"
+-rm -fr $PACKAGENAME
+
+ echo -ne "\nAll done. ;)\n"
+
diff --git a/x11-themes/nuvox/nuvox-07.1-r1.ebuild b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
index 328020ee4d52..7770506ddd90 100644
--- a/x11-themes/nuvox/nuvox-07.1-r1.ebuild
+++ b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
MY_P=nuvoX_${PV}
@@ -12,18 +12,13 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="virtual/imagemagick-tools[png]"
-
RESTRICT="strip binchecks"
-S=${WORKDIR}/${MY_P}
+BDEPEND="virtual/imagemagick-tools[png]"
-src_prepare() {
- sed -i -e '/rm -fr/d' -e '/tar cf/d' buildset || die
-}
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-07.1-fix-buildset.patch )
src_compile() {
./buildset || die
@@ -31,8 +26,8 @@ src_compile() {
src_install() {
dodoc nuvoX_0.7/readme.txt
- rm nuvoX_0.7/{readme,license}.txt
+ rm nuvoX_0.7/{readme,license}.txt || die
insinto /usr/share/icons/${PN}
- doins -r nuvoX_0.7/*
+ doins -r nuvoX_0.7/.
}